LED front blinkers not working - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-05-2012, 05:53 AM
Premium Member
 

Join Date: Jan 2011
Location: Depends on the job
Posts: 307
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
LED front blinkers not working

I ordered some LED front blinkers and after the install when I use the blinker every light on the truck flashes. I contacted the seller on Ebay that I bought them from and got this reply-"Ford is known to have flicker problem. you might want to try out the load resistors. If you dont you can return for refund. let us know." Does anyone know what part I need or anyone else using these bulbs?

2X 60 SMD 3157 3057 LED LIGHT BULB WHITE/AMBER TURN SIGNAL TAIL LAMP SIDE MARKER | eBay
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-05-2012, 09:34 AM
Member
 

Join Date: Mar 2011
Location: Alva, FL (Ft. Myers)
Posts: 84
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I'm not sure of the part number, but I believe you can order the electronic flasher relay from v-leds.com. Its a P.I.T.A. to get to, but not outrageously difficult. That will be a better solution, in my opinion, than the load resistors. Problem with resistors is they get really hot when your running current through them, so you'll have to make sure you have them positioned so as not to melt anything inadvertently. Additionally, I would send them back those bulbs anyway. A 60 smd LED setup without heatsinks or aluminum boards is going to get very hot as well. This shortens the life of the LEDS and can lead to premature failure.
Reply With Quote Quick reply to this message
  #3  
Old 03-05-2012, 09:39 AM
Premium Member
 

Join Date: Jan 2011
Location: Depends on the job
Posts: 307
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I ordered the load resistors. We will see how long they hold up for. Theses the right ones?

Two (2) pieces 50W 6-Ohm Load Resistors LED Bulbs Turn Signal Lights Flash Fix | eBay
Reply With Quote Quick reply to this message
  #4  
Old 03-05-2012, 09:41 AM
Member
 

Join Date: Mar 2011
Location: Alva, FL (Ft. Myers)
Posts: 84
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Just read your list of mods and figured I'd add that I have my X in the shop now being "upgraded" with the 07 Harley front end. I think we are probably looking at similiar paths with our lighting. I am ordering the Retro Digital 5k HID setup and will also be putting the switchbacks in the turn signals with a matching 5K color temp for the white LEDS. The site I mentioned previously:

Blinker/Warning Fix

and these are really nice switchbacks, you get what you pay for (usually):

Exterior LED Bulbs - Turn Signal LED

Scroll down some on that page to see the switchbacks.
Reply With Quote Quick reply to this message
  #5  
Old 03-05-2012, 10:17 AM
Premium Member
 

Join Date: Jan 2011
Location: Depends on the job
Posts: 307
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
They are exspensive.. $114 for a pair
Reply With Quote Quick reply to this message
  #6  
Old 03-05-2012, 11:30 AM
Premium Member
 

Join Date: Jan 2011
Location: Depends on the job
Posts: 307
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ended up ordering these instead-

3 OHM 50W 4 BULB LED LOAD EQUALIZER RESISTORS TURN SIGNAL BLINKER FIX WITH MOUNTING PLATES AND COVERS
Reply With Quote Quick reply to this message
  #7  
Old 03-05-2012, 01:41 PM
Compression Ignition Addict
 

Join Date: Jul 2008
Location: Wake Forest, NC
Posts: 3,836
Thanks: 12
Thanked 13 Times in 11 Posts
Feedback Score: 0 reviews
A $10 electronic flasher relay from advanced auto will fix the rapid flash, but if it is turning on all the light s like you said, you have another problem. If the parking lights are turning on, the bulb is shorting in a way that is is sending power through to the parking light. I had a bad bulb and when I turned the parking light on, the signal on the cluster would illuminate. So when I bench tested the bulb, sure enough the one trace would illuminate the parking and signal part of the bulb.
Reply With Quote Quick reply to this message
  #8  
Old 03-05-2012, 01:44 PM
Premium Member
 

Join Date: Jan 2011
Location: Depends on the job
Posts: 307
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by belz View Post
A $10 electronic flasher relay from advanced auto will fix the rapid flash, but if it is turning on all the light s like you said, you have another problem. If the parking lights are turning on, the bulb is shorting in a way that is is sending power through to the parking light. I had a bad bulb and when I turned the parking light on, the signal on the cluster would illuminate. So when I bench tested the bulb, sure enough the one trace would illuminate the parking and signal part of the bulb.
Would that explaine this?
Running light fuse keeps popping?
Reply With Quote Quick reply to this message
  #9  
Old 03-05-2012, 01:52 PM
Premium Member
 

Join Date: Jan 2011
Location: Depends on the job
Posts: 307
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
After I installed the passenger side I went in the truck to test it out and the blinker light was already on. So I thought maybe they both had to be plugged in and went to the cab and both lights were on. Tryed the blinkers and everything flash down to the dually fender lights. I have the bumper offf and lights loose. Just not sure where to start.
Reply With Quote Quick reply to this message
  #10  
Old 03-06-2012, 01:01 AM
Member
 

Join Date: Mar 2012
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Howdy,

Sounds like we are havin similar problems my bed and headache have all led's on it now and an HD flasher causes my rapid flashin. But the lights work fine otherwise.

I saw a set of lights I liked and ordered them

PT-A35-SFA series Tail Lamp

for the headache, when I installed the driver side light I was impressed the light worked just fine, so i put in the pass side and both lights started flashin and stayin on no matter what I did. I unplugged the driver side light but the passenger side was still goin nuts. I reinstalled the driver side light and unplugged the passenger light and all was right with the world again.

I'm great at doin electrical projects I always let the smoke out at least once.

In other words, any help would be nice

AJ
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:16 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors