Electrical problem - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 01-06-2012, 08:42 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Nov 2005
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Angry Electrical problem

Hey gang,
I recently replaced my alternator on my 02 and now after driving a few miles (approx. 10) my voltage light flashes then the entire dash goes of and on. It will actually continue doing this a few times. I'm not sure if the alternator has anything to do with this problem but thought it was worth mentioning since that is the only recent repairs done.
Do you think its a faulty alternator or something else?

thanks in advance for your assistance!
Old_School is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 01-06-2012, 09:02 AM
Compression Ignition Addict
 
dentexpowerstroke's Avatar
 
Join Date: Sep 2011
Location: Denton, tx
Posts: 1,388
Thanks: 0
Thanked 16 Times in 13 Posts
Mentioned: 1 Post(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
check all of your grounds and connections. i had this happen when i over looked tightening up a ground

Sold 2001 f250 ccsb 4x4 400/400, dual terminators, swamps 80mm bfh, headers, bts and all the usual supporting mods. 715hp fuel only.

06 f250 ccsb king ranch

12 f250 lariat ultimate
dentexpowerstroke is offline  
post #3 of 6 Old 01-06-2012, 10:45 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Nov 2005
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Wouldn't the problem occur constantly if it was a loose ground?
Old_School is offline  
post #4 of 6 Old 01-06-2012, 09:54 PM
Compression Ignition Addict
 
Join Date: Dec 2011
Posts: 281
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
Have the altenator tested to rule that out.
mgassel is offline  
post #5 of 6 Old 01-09-2012, 05:40 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Nov 2005
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Okay gang, I took both batteries out and the alternator off, went to Autozone. The batteries tested good, but the alt. tested bad. Since I bought the alt from Orielly's, I took it by there and had them test it. They tested the alt 3 times and it passed all three.
Suggestions where to look from here?
Old_School is offline  
post #6 of 6 Old 01-09-2012, 10:31 PM
Compression Ignition Addict
 
Join Date: Dec 2011
Posts: 281
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by Old_School View Post
Okay gang, I took both batteries out and the alternator off, went to Autozone. The batteries tested good, but the alt. tested bad. Since I bought the alt from Orielly's, I took it by there and had them test it. They tested the alt 3 times and it passed all three.
Suggestions where to look from here?
The first problem is you went to vatozone they do not know how to get out of a wet paper sack.
mgassel is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome