Horn not working - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 11-26-2011, 05:55 PM Thread Starter
Powerstroke.org Rookie
 
BeastinFillup's Avatar
 
Join Date: Oct 2011
Location: Schertz TX
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Horn not working

Well the horn in my 2001 isn't working. The horn itself works and the button in the steering wheel works because when I press it I hear the relay click also when I press the panic button on my remote the lights flash and no horn. Any suggestions would be greatly appreciated.

Phil
2001 F-250 7.3 4x4- S&B cold air intake, 4" Diamond Eye Turbo back exhaust, Banks high boost compressor wheel, 05-07 front end conversion, Foil delete, Zoodad mod, lots more to come

BeastinFillup is offline  
post #2 of 7 Old 11-26-2011, 05:59 PM
Compression Ignition Addict
 
mxfever090's Avatar
 
Join Date: Jun 2010
Location: Central Michigan
Posts: 755
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 7
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Try swapping with a known good relay. Just because you hear the "click" doesn't mean the contacts aren't burnt out.

Jason

O.T.F.D. Volunteer 19

Great White - 2003 7.3l F-250 4x4 CCSB -102,000 miles and tickin
DIY intake - 4" Straight pipe - HPX - CAT ELC - 203 t stat - billet t stat housing - coolant filter - dual alt radiator hose - 12V Air compressor - 5 gallon air tank - Air line quick connects - AIR HORNS!

Hers: 2013 VW Jetta TDI

mxfever090 is offline  
post #3 of 7 Old 11-26-2011, 06:18 PM Thread Starter
Powerstroke.org Rookie
 
BeastinFillup's Avatar
 
Join Date: Oct 2011
Location: Schertz TX
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Just tried with two different brand new relays still no horn. I checked all of the fuses too and everything looks good. Is there anything other than the fuse box in the dash and the one under the hood that would effect the horn?

Phil
2001 F-250 7.3 4x4- S&B cold air intake, 4" Diamond Eye Turbo back exhaust, Banks high boost compressor wheel, 05-07 front end conversion, Foil delete, Zoodad mod, lots more to come

BeastinFillup is offline  
post #4 of 7 Old 11-26-2011, 06:26 PM
Compression Ignition Addict
 
mxfever090's Avatar
 
Join Date: Jun 2010
Location: Central Michigan
Posts: 755
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 7
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
How do you know the horn works? It can be a sob to get too. If memory serves me correct it's a green wire with a yellow tracer that goes through the fire wall. Pull the fuse panel down and make sure your getting the signal from the column.

Jason

O.T.F.D. Volunteer 19

Great White - 2003 7.3l F-250 4x4 CCSB -102,000 miles and tickin
DIY intake - 4" Straight pipe - HPX - CAT ELC - 203 t stat - billet t stat housing - coolant filter - dual alt radiator hose - 12V Air compressor - 5 gallon air tank - Air line quick connects - AIR HORNS!

Hers: 2013 VW Jetta TDI

mxfever090 is offline  
post #5 of 7 Old 11-26-2011, 06:39 PM Thread Starter
Powerstroke.org Rookie
 
BeastinFillup's Avatar
 
Join Date: Oct 2011
Location: Schertz TX
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
well I put a new 7.3 in the truck and when I did that I went ahead and took the horn out of my old truck tested it then installed it. The horn worked when I connected it to a car battery. Right now i'm not getting any power to the horn when its activated. Do you think if could be the fuse panel?

Phil
2001 F-250 7.3 4x4- S&B cold air intake, 4" Diamond Eye Turbo back exhaust, Banks high boost compressor wheel, 05-07 front end conversion, Foil delete, Zoodad mod, lots more to come

BeastinFillup is offline  
post #6 of 7 Old 11-26-2011, 06:47 PM
Compression Ignition Addict
 
mxfever090's Avatar
 
Join Date: Jun 2010
Location: Central Michigan
Posts: 755
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 7
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Check with a test light and see if your getting power to the horn. It only goes from the fuese panel, throught the bulkhead connecter to the horn. Start from the horn connector and work your way back.

Jason

O.T.F.D. Volunteer 19

Great White - 2003 7.3l F-250 4x4 CCSB -102,000 miles and tickin
DIY intake - 4" Straight pipe - HPX - CAT ELC - 203 t stat - billet t stat housing - coolant filter - dual alt radiator hose - 12V Air compressor - 5 gallon air tank - Air line quick connects - AIR HORNS!

Hers: 2013 VW Jetta TDI

mxfever090 is offline  
post #7 of 7 Old 11-26-2011, 06:49 PM Thread Starter
Powerstroke.org Rookie
 
BeastinFillup's Avatar
 
Join Date: Oct 2011
Location: Schertz TX
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ok ill try it tomorrow in the daylight and report my findings then. Thanks

Phil
2001 F-250 7.3 4x4- S&B cold air intake, 4" Diamond Eye Turbo back exhaust, Banks high boost compressor wheel, 05-07 front end conversion, Foil delete, Zoodad mod, lots more to come

BeastinFillup is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome