HELP TRUCK DOWN - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-07-2011, 07:58 AM
Powerstroke.org Fanatic
 

Join Date: May 2006
Location: houston
Posts: 147
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
HELP TRUCK DOWN

Well i have a 01 F350 dually with 237k miles that was running fine till this morning, started truck up and white smoke galore, then proceeded to leave neighborhood and touch the throttle and black smoke everywhere, no power, funky idle,,,,no check engine light . its at neighborhood shop and they said something about EGR....? Does this truck have one since it has no emissions, i did notice coolant was low when i had hood up. I was thinking that metal hose from turbo pedastal ....truck has a 4 pos chip and wife said sat it wouldnt boost past 10 lbs ......? ANY IDEAS
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-07-2011, 08:28 AM
Compression Ignition Addict
 

Join Date: Aug 2009
Location: near madison wisconsin
Posts: 161
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
no egr cooler on 7.3L you may have bad turbo or injector - usually grey/white and black smoke is over fueling one of the injectors may also be bad
Reply With Quote Quick reply to this message
  #3  
Old 11-07-2011, 09:21 AM
Compression Ignition Addict
 

Join Date: Jul 2011
Location: Wayne County, Ohio
Posts: 826
Thanks: 2
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
change your fuel filter, and yes no egr. If it was me and a shop said anything about an egr in a 7.3 id get as far away from that shop that I can
Reply With Quote Quick reply to this message
  #4  
Old 11-07-2011, 09:24 AM
Powerstroke.org Fanatic
 

Join Date: May 2006
Location: houston
Posts: 147
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Just out of curiosity I googled ford f350 egr tube with 7.3 and a frigging part number came up. I am so confused .
Reply With Quote Quick reply to this message
  #5  
Old 11-07-2011, 04:21 PM
Banned
 

Join Date: Oct 2009
Location: Riverside/Norco, Ca
Posts: 3,771
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 2 reviews
There is an exhaust back pressure sensor on a tube.. thats about it... no 7.3 ever had egr, guaranteed.
Reply With Quote Quick reply to this message
  #6  
Old 11-07-2011, 05:03 PM
Compression Ignition Addict
 

Join Date: Apr 2007
Location: Wright City, MO
Posts: 2,710
Thanks: 3
Thanked 4 Times in 4 Posts
Feedback Score: 1 reviews
Your truck DOES NOT have an EGR. Take it to a different shop who knows stuff about the 7.3.
Reply With Quote Quick reply to this message
  #7  
Old 11-09-2011, 04:04 AM
Compression Ignition Addict
 

Join Date: Jul 2011
Location: Wayne County, Ohio
Posts: 826
Thanks: 2
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Any updates?

Sent from my DROID X2 using AutoGuide App
Reply With Quote Quick reply to this message
  #8  
Old 11-09-2011, 08:56 AM
Powerstroke.org Fanatic
 

Join Date: May 2006
Location: houston
Posts: 147
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
ok .....so far its running again, replaced the fuel pump on frame[? didnt know it was bad but ok], truck runs fine, tested for blown head gaskets ....nope, no boot leaks or check engine lights.......topped of coolant and will drive around but seems to be fine........frankly i am confused but I have the big ***** back .
Reply With Quote Quick reply to this message
  #9  
Old 11-09-2011, 09:06 AM
Compression Ignition Addict
 

Join Date: May 2009
Location: Claremont, NC
Posts: 545
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I had mine go out last year but smoke for low fuel pressure is blue. Wouldnt boost or wouldnt go over 10 mph. When you were describing it in first post it all seemed like fuel pump except for the black smoke.
Reply With Quote Quick reply to this message
  #10  
Old 11-09-2011, 09:24 AM
Powerstroke.org Fanatic
 

Join Date: May 2006
Location: houston
Posts: 147
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Blue.....black ....it was dark and hard to see......will drive it around and see if any issues come back
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:55 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors