injector install help needed - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-12-2011, 05:19 PM
Compression Ignition Addict
 

Join Date: Dec 2007
Posts: 2,858
Thanks: 6
Thanked 1 Time in 1 Post
Feedback Score: 2 reviews
injector install help needed

I have installed many injectors but feel I have had problems with the remans ticking. I bought a new alliant injector today and installed in in place of an old but quiet running injector. The thing is I always coat the o rings with oil. I remove the glow plug and crank the motor to not hydro lock it. One thing i never do is this(taken on line from black cloud diesel)
"

After checking the oil level, but with the injector wires disconnected so the injectors
will not fire (You can also remove the #9 Maxi fuse in the under hood Power
Distribution Box), crank the engine for 30-40 seconds to get oil circulating and
pressurizing. Then continue with reassembly and crank the engine for 30-40 seconds
every 15-20 minutes, or until you complete 4-5 cycles. This cycle of cranking andresting
gives time for air in the injectors to bleed out and work its way to the top of the rails.
When everything is reassembled and you're ready to start the engine, top off the oil
rail and reservoir one last time.

If the engine is started while there is still air inside the nozzle, there may not be
sufficient fuel to cushion the nozzle needle and it can crack the nozzle tips. Air inside
the fuel cavity of the plunger and barrel has similar effects on the piston."
When i first tried to start my motor(i only removed one injector so did not lose much oil in the rails or fuel, went fast) The engine started with in say 5 seconds. i did not have to crank long. The motor or actually this new injector fired blanks for a few seconds. i could hear it going snap snap snap. I turned the motor off and restarted it. That was gone but i now have my annoying as all hell tick tick tick back. The old injector was fairly quiet.
I had tried 3 injectors from beans remans, and now one new one. several different holes but they were ticking. Its like I get 1 out of 4 to go in and be quiet?
any ideas?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 10-12-2011, 06:26 PM
Compression Ignition Addict
 

Join Date: Dec 2007
Posts: 2,858
Thanks: 6
Thanked 1 Time in 1 Post
Feedback Score: 2 reviews
bump anyone???
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:33 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors