ABS Light is on and Speedo Problem - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 8 Old 09-29-2011, 06:41 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Nov 2009
Location: Barstow, CA
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
ABS Light is on and Speedo Problem

I have a 99 F250 Super Duty 7.3L, with Manual Trans, recently the ABS light came on and stays on. Also, my speedometer only starts to work once i reach a speed of about 30 or 35 mph. What should i check first?
cedave is offline  
post #2 of 8 Old 09-30-2011, 03:35 AM
Powerstroke Junkie


 
NCHornet's Avatar
 
Join Date: Aug 2006
Location: Mayberry, NC
Posts: 8,308
Thanks: 0
Thanked 52 Times in 11 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
You need to have truck scanned for codes. The FREE scans won't work as our trucks are not OBD II compliant. My bet is on VSS on rear diff, $30 and 5 min to replace. 8mm socket or wrench to remove old sensor. If you are close to me I will scan it for FREE.

NCH
Proud Father of USAF Airman


2000 F350 DRW,CC,LB, 4X4, Western Hauler Pkg.
Ford AIS/ BTM, FTVB
My CCV MOD, Coolant filter
06 Grill, 05 lights,6.0 trans cooler
Cyro/Hawks, JVC Touchscreen HU, JL C5's, Infinity 800watt amp,
DP tunes, 60 tow/80 e/120 race, on a SCT2 tuner
P3 controller, Brite Box Turbo Lifesaver
KMC Wheels x 4

http://s132.photobucket.com/user/NCH...=recent&page=1

Friends Don't Let Friends Drive Trucks With Generic Tunes
NCHornet is offline  
post #3 of 8 Old 09-30-2011, 03:36 AM
Powerstroke Junkie


 
NCHornet's Avatar
 
Join Date: Aug 2006
Location: Mayberry, NC
Posts: 8,308
Thanks: 0
Thanked 52 Times in 11 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Barstow CA , to far for me to go sorry?

NCH
Proud Father of USAF Airman


2000 F350 DRW,CC,LB, 4X4, Western Hauler Pkg.
Ford AIS/ BTM, FTVB
My CCV MOD, Coolant filter
06 Grill, 05 lights,6.0 trans cooler
Cyro/Hawks, JVC Touchscreen HU, JL C5's, Infinity 800watt amp,
DP tunes, 60 tow/80 e/120 race, on a SCT2 tuner
P3 controller, Brite Box Turbo Lifesaver
KMC Wheels x 4

http://s132.photobucket.com/user/NCH...=recent&page=1

Friends Don't Let Friends Drive Trucks With Generic Tunes
NCHornet is offline  
post #4 of 8 Old 09-30-2011, 03:56 AM
Compression Ignition Addict
 
Galaxie's Avatar
 
Join Date: Oct 2009
Location: Robinson Twp PA (Pittsburgh)
Posts: 4,539
Thanks: 2
Thanked 3 Times in 3 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via AIM to Galaxie
If it isn't your vss I would be surprised. My 03 ate 2 and my 06 ate one. Actually on the 06, same exact symptom you are describing!!!!

Colin
59-68Galaxies, Fairlanes
54 Ford Skyliner Glass Top
60 Country Sedan Wagon
87/93 5.0s 347
Buy/Sell/Trade/Service 40s50s60s cars!
06 F350 Dark Stone XLT FX4
SCTX3 Custom Tunes
ARP Head Studs
EGR Cooler gone
MBRP Stright Pipe
Edge Insight
20" Harleys 35" AT2
2011 Tailgate
Eaton TrueTrac
2" Leveling
Black Windows/lights
Blue Spring
03 Turbo
Galaxie is offline  
post #5 of 8 Old 09-30-2011, 07:12 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Nov 2009
Location: Barstow, CA
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Thanks for the info. I'll check out the VSS (i'm assuming this is the vehicle speed sensor on the rear diff).
cedave is offline  
post #6 of 8 Old 09-30-2011, 07:32 AM
Powerstroke.org Fanatic
 
Join Date: Apr 2011
Location: San Jose, CA
Posts: 148
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Had my sensor replaced as well.

Peter

alradco is offline  
post #7 of 8 Old 09-30-2011, 08:28 AM
Compression Ignition Addict
 
Quickhorse's Avatar
 
Join Date: Dec 2007
Location: Akron/Canton, Ohio
Posts: 744
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by Galaxie View Post
If it isn't your vss I would be surprised. My 03 ate 2 and my 06 ate one. Actually on the 06, same exact symptom you are describing!!!!
Nice Avatar pic!!

Quote:
Originally Posted by cedave View Post
Thanks for the info. I'll check out the VSS (i'm assuming this is the vehicle speed sensor on the rear diff).
Yes, Vehicle Speed Sensor on the rear diff. I have a brand new one from Ford in my garage for a spare.

2008 F350 CCSB FX4 Amsoil fluids, S&B intake, 5" exhaust, Egr delete, Boss V plow, Mega Duty Title mod. http://www.analyticpc.net/
Winch Piece for ATV or Jeep http://www.ebay.com/itm/231641393025?ssPageName=STRK:MESELX:IT&_trksid=p39 84.m1555.l2649
Quickhorse is offline  
post #8 of 8 Old 09-30-2011, 01:59 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Nov 2009
Location: Barstow, CA
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Well $15 later (Autozone) and problem fixed. You guys were right on the money, it was the rear ABS brake sensor, as the folks at Autozone refered to it as.
Anyway, thanks again for the advice and the fix.

Oh, and Galaxie, I too enjoyed your avatar!!!!!!!!!!
cedave is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome