2003 a/c problems - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-28-2011, 12:51 PM
Powerstroke.org Rookie
 

Join Date: Aug 2011
Location: biloxi ms
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
2003 a/c problems

hello and thanks for the help in advance
let me start by saying that i an new to the forum but not to the f-250 i have 3 of them .
here is the problem i just got an 03 with the 7.3 and lets just say needs some work but it was cheap so what the hay
i am not getting cold air out of the a/c i have checked everything that i know to check and am getting nothing.
i changed the clutch on the ac compresor and have charged it with at least 3 cans of freon . the compresor is kicking on and seems to be working fine.
i have checked the blend door acuator and it is working correct. everything is hooked up to the best of my knowing
anyone have any tips that i might try. thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-28-2011, 01:35 PM
Powerstroke.org Fanatic
 

Join Date: Jul 2011
Posts: 135
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
first off. what size cans? 8oz?

also is compressor cycling quickly or just normal?

I'm assuming that its blowing out of vents just blowing warm air...

also when you changed just clutch ? if so you should not have needed to add freon unless was low. if so then i would start off looking for a leak..

I'm not quite sure the exact amount of freon these trucks hold maybe someone else could chime in on that. but first off thats what needs to be made sure of is that you have the correct amount. too much compressor will kick on then high press. switch will shut it off due to too much pressure.
Reply With Quote Quick reply to this message
  #3  
Old 08-28-2011, 02:05 PM
Powerstroke.org Rookie
 

Join Date: Aug 2011
Location: biloxi ms
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
sorry a little more info
i had the system apart to replace the engine in the truck
then put 12 oz cans in it
the compresor is now staying on it does not cycle i havnt checked my other truck to see if this is normal or not .
i dont think that the system is completly full but it will not take any more freon
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:18 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors