Need Some Help with This Sound - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-23-2011, 04:21 AM
Member
 

Join Date: Mar 2010
Posts: 87
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Need Some Help with This Sound

This happens all the time. It sounds like a exhaust leak or lifter hanging up. No exhaust leak, checked for that. It seems to be coming from the right (passenger) side of the motor. Engine idles smooth. It's just annoying. Could it be that I need the crossover tube I've heard and read about? I'm leaving next Monday on a 2000 mile (round) trip. Can I run it without getting it fixed?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-23-2011, 06:03 AM
Banned
 

Join Date: Jan 2011
Location: Maine
Posts: 4,240
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 5 reviews
Send a message via Skype™ to ToMang07
Have you checked your intercooler boots for any cracks/holes or if they blew off?
Reply With Quote Quick reply to this message
  #3  
Old 08-23-2011, 07:40 AM
Powerstroke.org Rookie
 

Join Date: Aug 2011
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Can you hear the noise at idle? I have a ticking that sounds like an exhaust leak, coming from the right hand side of the engine, but only when I get on the go pedal, nothing at idle really.

J
Reply With Quote Quick reply to this message
  #4  
Old 08-23-2011, 07:53 AM
Member
 

Join Date: Mar 2010
Posts: 87
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
I checked the boots and they seem to be OK. There is not a distinct tick at idle. The time I hear it the most is when the engine is just cruising or de-acceleration. If I step on it a little it isn't as loud or maybe it's gone completely. Truck has plenty of power. More then I probably need. I should maybe mention that it has stage 2 injectors also. Chip is from BTS in Ar. It runs great, just that ticking, missing, or whatever it is sound. Thanks for the responses.
Reply With Quote Quick reply to this message
  #5  
Old 08-23-2011, 07:57 AM
Banned
 

Join Date: Jan 2011
Location: Maine
Posts: 4,240
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 5 reviews
Send a message via Skype™ to ToMang07
Quote:
Originally Posted by BigDs_2000 View Post
I checked the boots and they seem to be OK. There is not a distinct tick at idle. The time I hear it the most is when the engine is just cruising or de-acceleration. If I step on it a little it isn't as loud or maybe it's gone completely. Truck has plenty of power. More then I probably need. I should maybe mention that it has stage 2 injectors also. Chip is from BTS in Ar. It runs great, just that ticking, missing, or whatever it is sound. Thanks for the responses.
That sounds more like a stuck lifter, then. Depending on how many miles you have on your oil change, might be worth your money to do an oil change and put a good synthetic in it with some Rev-X. JMHO.
Reply With Quote Quick reply to this message
  #6  
Old 08-23-2011, 08:21 AM
Member
 

Join Date: Mar 2010
Posts: 87
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
I just changed the oil less then 600 miles ago. Always change my oil at 3000 miles.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:50 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors