2000 F250 problems - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 08-08-2011, 10:58 AM Thread Starter
Powerstroke.org Rookie
Join Date: Aug 2011
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
2000 F250 problems

I just bought a 2000 F250 4x4 with 6 speed manual 3 weeks ago. The truck has 106000 miles on it. I started having intermittent problems with the truck losing power. It never ran rough or smoked, it was just very slow revving like it wasn't getting enough fuel. Shut the truck down and it ran fine for a week. I have changed the oil and fuel filter. About a week ago the problem started again but this time the truck would randomly go to idle with SES light on. The diesel shop pull a TPS code (not sure of # now). I replaced the pedal assembly with a new OEM part. The truck ran fine for a few miles and is back to doing the same thing. The truck will run like normal after setting all night but only for about 1/2 mile then lack of power and randomly returning to idle when shifting. Sorry for the long post but would appreciate some guidance.
amc is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome