Huge electrical problem...need help bad!! - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 06-29-2011, 07:57 PM Thread Starter
Member
 
Join Date: Jul 2010
Posts: 30
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Huge electrical problem...need help bad!!

Hopefully someone can help me out with this...but i pulled my truck in the garage to put my new napa filter in and removed the air box and after doing so i went to start the truck and had no power on the ignition switch...also, my headlights wouldn't even turn on. So I ended up wiggling some wires around on the drivers side engine bay and theres all sorts of different harness connections right there, and my lights came on and off a couple times. Well...now i can't get them to do anything. No matter how much I wiggle on them.

I do know theres is a harness going to the tranny that had been rubbed by the driveshaft and went thru a couple wires. I pulled it away and made sure none are touching anything. But could this cause the truck not to start? I unhooked all four battery connections and then hooked back up, they seem alright. And both batteries have over 12 volts. I'm stumped. Any help would be awesome!
nhpick02 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 06-29-2011, 08:39 PM
Powerstroke.org Fanatic
 
Join Date: Dec 2009
Location: new site,alabama
Posts: 122
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
check all the connections. make sure they are inserted all the way or tight. then check all fuses. when you wiggled them and the lights flickered you may have popped a fuse. wiggle the relays and see if any thing changes. need to repair wires going to tranny soon

00 F350 super crew lariat 326k and still pullin (sold)
03 F250 4x4 ccsb lariat 290k and going strong
4" rough country
dp 5 pos tunes s b air box
4" stright thru exhaust
35/12.50-18 fierce attitude mt's with incubus wheels
tri pillar gauges
95 F450 xlt extra long wheel base
dacco tri disc billet converter (project service truck)244k
00 F350 super crew xlt (future project)
needs engine rebuild
220k
arduece is offline  
post #3 of 3 Old 07-01-2011, 09:05 AM Thread Starter
Member
 
Join Date: Jul 2010
Posts: 30
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i found the problem. on the drivers side fender well there is a small terminal wheres two wires connect. the lug the wire coming out had corroded and broke, leaving me with no power at all. but anyways, its fixed now and in case this happens to someone else that'll be a place to look.
nhpick02 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome