CPS? crank pos or cam pos sensor - Ford Powerstroke Diesel Forum

 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 06-18-2011, 09:35 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jun 2011
Location: tacoma
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
CPS? crank pos or cam pos sensor

Ok newb here but CPS?? is that the crank position sensor? or is it a cam possition sensor? and where are they located? the truck is running rough ocasionaly and want to replace the cps because a lot of what im reading is the same issues that i am having

thanks
i11m10c2 is offline  
post #2 of 6 Old 06-18-2011, 12:30 PM
Banned
 
Join Date: Jan 2011
Location: Maine
Posts: 4,240
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 5 reviews
Send a message via Skype™ to ToMang07
ToMang07 is offline  
post #3 of 6 Old 06-18-2011, 09:51 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jun 2011
Location: tacoma
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
thanks for the help

Hey buddy thanks for the help. i went to parts house and the only one they stock is a grey one so i will give it a try! If it runs worse then i will give you a yell and see if you have any of the black ones left as well as another o-ring. No real problems with the truck, I just bought it and dosent run and idle as smooth as i think it should (compared to my buddies 2000 excursion!)

BTW where in maine are you roughly?

ok thanks for the help
i11m10c2 is offline  
post #4 of 6 Old 06-19-2011, 07:03 AM
Powerstroke.org Fanatic
 
Join Date: Feb 2011
Posts: 115
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
replaced mine yesterday, used guzzles guide. quick and easy fix to the truck stalling and rpm dropping erratically. i bought one from the ford dealership, it is the grey one was 17.00

2001 F-350 Crew Cab 4X4
Completely Stock
bwvick is offline  
post #5 of 6 Old 06-19-2011, 12:37 PM
Banned
 
Join Date: Jan 2011
Location: Maine
Posts: 4,240
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 5 reviews
Send a message via Skype™ to ToMang07
Quote:
Originally Posted by i11m10c2 View Post
Hey buddy thanks for the help. i went to parts house and the only one they stock is a grey one so i will give it a try! If it runs worse then i will give you a yell and see if you have any of the black ones left as well as another o-ring. No real problems with the truck, I just bought it and dosent run and idle as smooth as i think it should (compared to my buddies 2000 excursion!)

BTW where in maine are you roughly?

ok thanks for the help
No problem, but I probably should have said this in my post, although I think guzzle mentions it, you should only buy a Ford or International CPS... some of the no-name ones cause problems.

And always keep one in the glove box!
ToMang07 is offline  
post #6 of 6 Old 06-19-2011, 04:54 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jun 2011
Location: tacoma
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Ok there i put new cps in and seems to have smoothed out some or just me but i have a dead spot in the accelerator pedal i wonder if the sensor on that is gone or do i have another issue im not seeing the truck still starts quick some times and sometimes takes 3-4 revolutions.
the dead spotseems to be in the first 3-5 milimeters of travel
i11m10c2 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome