Electrical Issue - Windows - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-04-2011, 06:11 PM
Member
 

Join Date: Feb 2011
Location: Birmingham, AL
Posts: 76
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Question Electrical Issue - Windows

Well of course right after I clean up the truck for the day, I run into an issue as I go out for the night.

After I started the truck up I go to put the windows down and none of them will go down. I noticed the driver's side switch panel isn't illuminated like the other 3 doors, but the windows still won't go down from the individual doors either.

I checked the fuses, swapped some around and still nothing.

I noticed my courtesy door light at the bottom of my driver's door was on while I was moving as well.

I didn't spray anything inside the truck or under the hood when I cleaned today, everything just started going wrong right when I got in it.

I haven't had any of these problems before, and I didn't even have these problems earlier today when I was driving.

Any ideas or suggestions of what could be going on or should I just wait till Monday when I can take it into someone who knows auto electrical?

Last edited by M3xpress; 06-04-2011 at 07:20 PM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-04-2011, 07:18 PM
Member
 

Join Date: Feb 2011
Location: Birmingham, AL
Posts: 76
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Messed with it a little more and found a few more things out.

When you first start the truck the driver's side switch panel is illuminated, it is only when you try to use one of the window switches that the switch lights go out. When they go out, the courtesy light at the bottom of the driver's door comes on for whatever reason.

If I press the driver's window switch up, it turns off the courtesy light and the driver's switch panel lights back up.

It also appears all the door lock switches are working.
Reply With Quote Quick reply to this message
  #3  
Old 06-04-2011, 08:17 PM
Compression Ignition Addict
 

Join Date: Feb 2011
Location: upstate ny
Posts: 2,254
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 7 reviews
My truck did the same thing-what I determined was that it was losing the ground to the window motor. Try running a jumper wire to the large ground wire going into the switch-ground it to the chassis, I bet the windows goes down. Or, see if that wire loses ground when you try to hit the window switch.
Reply With Quote Quick reply to this message
  #4  
Old 06-05-2011, 06:28 AM
Member
 

Join Date: Feb 2011
Location: Birmingham, AL
Posts: 76
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Quote:
Originally Posted by dazdillenger View Post
My truck did the same thing-what I determined was that it was losing the ground to the window motor. Try running a jumper wire to the large ground wire going into the switch-ground it to the chassis, I bet the windows goes down. Or, see if that wire loses ground when you try to hit the window switch.
Where is the large ground wire, would losing that ground cause all the windows from not going down?
Reply With Quote Quick reply to this message
  #5  
Old 06-05-2011, 06:35 AM
Powerstroke.org Rookie
 

Join Date: Jun 2008
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I am also expericening the same thing, I have opened and closed the driver's door a couple times and then everything comes back. If you find any concrete info on this please let me know, I have changed every relay, I thought that would be related but that did not help.
Reply With Quote Quick reply to this message
  #6  
Old 06-05-2011, 07:39 AM
Compression Ignition Addict
 

Join Date: Feb 2011
Location: upstate ny
Posts: 2,254
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 7 reviews
yes, losing the ground caused it. It is going into the driver's side switch!
Reply With Quote Quick reply to this message
  #7  
Old 06-05-2011, 12:07 PM
Powerstroke.org Rookie
 

Join Date: Jun 2008
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Inside the driver's door? the existing ground is it to the door frame?
Reply With Quote Quick reply to this message
  #8  
Old 06-05-2011, 12:11 PM
Compression Ignition Addict
 

Join Date: Feb 2011
Location: upstate ny
Posts: 2,254
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 7 reviews
take off the swich panel-you will see all the wires going into the swtiches. There is a thick gauge black ground wire. It is VERY SIMPLE TO FIND! you are overthinking this. I don't know where it grounds, but check it by starting the truck, checking it for ground, and then attempting to roll the window down. I bet it loses ground. If that is the case, run a new ground wire to the door and all will be well in the future.
Reply With Quote Quick reply to this message
  #9  
Old 06-05-2011, 04:41 PM
Powerstroke.org Rookie
 

Join Date: Jun 2008
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thank you, this is the first time this has happened and it isn't all the time. I will look into it.
Reply With Quote Quick reply to this message
  #10  
Old 06-06-2011, 06:21 AM
Member
 

Join Date: Apr 2011
Location: East Tennessee
Posts: 75
Thanks: 1
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Hey thanks, I am having about the same trouble, I will give this a try also....
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:38 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors