Higher EGTs after foil delete? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-19-2011, 07:23 PM
Banned
 

Join Date: Jul 2008
Location: Would rather be in WY
Posts: 3,782
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Higher EGTs after foil delete?

Might be completely unrelated to my foil delete, but my EGTs run about 850 degrees going 75 mph up a slight hill, while they used to run about 650/700. If I floor it I can easily hit 1,100.


Last edited by Austin G; 05-19-2011 at 07:26 PM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 05-19-2011, 07:31 PM
Premium Member
 

Join Date: Oct 2010
Location: fostoria ohio
Posts: 206
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
when i run 60 the egt's are about 600. when i run 70 there slighty over 700. so sounds about right going up a hill. also with a chip its so easy to bury ur egt gauge.
Reply With Quote Quick reply to this message
  #3  
Old 05-19-2011, 07:32 PM
Banned
 

Join Date: Jul 2008
Location: Would rather be in WY
Posts: 3,782
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I'm stock... Just putting that out there..

Your truck looks like Mudrunningpig's. Had my confused there for a second.
Reply With Quote Quick reply to this message
  #4  
Old 05-19-2011, 07:55 PM
Compression Ignition Addict
 

Join Date: Jun 2007
Location: Harrisville Mississippi
Posts: 484
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
get you a gtp38r they will cool off... mine did. they sound bad a** too.
Reply With Quote Quick reply to this message
  #5  
Old 05-19-2011, 09:35 PM
Banned
 

Join Date: Oct 2009
Location: Riverside/Norco, Ca
Posts: 3,771
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 2 reviews
well a lil common sense austin did you TIGHTEN your ic boots down good and is your boost the same? lol
Reply With Quote Quick reply to this message
  #6  
Old 05-19-2011, 09:38 PM
Banned
 

Join Date: Jul 2008
Location: Would rather be in WY
Posts: 3,782
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Dietoremain View Post
well a lil common sense austin did you TIGHTEN your ic boots down good and is your boost the same? lol
Yup, was at about 10 pounds.
Reply With Quote Quick reply to this message
  #7  
Old 05-20-2011, 05:25 PM
Powerstroke.org Rookie
 

Join Date: May 2011
Location: Waymart pa
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i have 03 7.3 4 inch down tube and chip and if im towing my egts go way too high fast its a 6 spd and i cant use the full power of truck do to climbing egts so i have to back off. any way to cool them off i have twin stacks and cold air intake.. any ideas?
Reply With Quote Quick reply to this message
  #8  
Old 05-20-2011, 05:44 PM
Premium Member
 

Join Date: Mar 2011
Location: AUBURNDALE, FL
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
water meth injection will help drop egts
Reply With Quote Quick reply to this message
  #9  
Old 05-20-2011, 06:03 PM
Compression Ignition Addict
 

Join Date: Nov 2009
Posts: 567
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Send a message via Yahoo to F250 Fever
Make sure all your boots are sealed tight, make sure there are no cuts slits of any kind in any of the boots, those are just a few ideas since ur sayin all you did is foil delete and those are the possibilities that may have happened.

how many lbs of boost areyou hitting at WOT? You should be around 16 17psi, if not you most likely have boost leak of some sort.
Reply With Quote Quick reply to this message
  #10  
Old 05-20-2011, 06:18 PM
Powerstroke.org Rookie
 

Join Date: May 2011
Location: Waymart pa
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Egts

Im only getting 14 psi boost wot. I just bought truck only has 100 k on it and its a 6 spd. I have a 99 7.3 with 210 k on it but its automatic boost pressure a lot higher in 20s. The new truck 2003 also has oil leak some where running down back of engine any ideas. Is there a common leak i should check first my 99 has no leaks ever?
Thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:44 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors