Trailer Brake not working - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-04-2011, 04:07 PM
Compression Ignition Addict
 

Join Date: Nov 2009
Posts: 213
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Trailer Brake not working

I bought a trailer brake controller from autozone with a plug and play harness and it lights up reading E1 (trailer not connected) when i have no trailer on. The weird thing is as soon as i turn my running lights on the controller shuts up. I learned this the hard way when the trailer breaks locked up doing 15... anybody know whats wrong?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-12-2011, 08:54 AM
Compression Ignition Addict
 

Join Date: Nov 2009
Posts: 213
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
to the top
Reply With Quote Quick reply to this message
  #3  
Old 04-12-2011, 09:05 AM
Illiana Chapter Director

 

Join Date: Feb 2008
Location: Bloomington, IN.
Posts: 12,334
Thanks: 5
Thanked 85 Times in 80 Posts
Feedback Score: 2 reviews
It plugs directly into the grey connector behind the lower dash panel cover or did you have to wire a plug to the controller and then plug it into the connector?
Reply With Quote Quick reply to this message
  #4  
Old 04-12-2011, 09:07 AM
Compression Ignition Addict
 

Join Date: Nov 2009
Posts: 213
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Well i bought the harness from autozone with the connector to the brake controller and the Ford plug. It plugged right in.
Reply With Quote Quick reply to this message
  #5  
Old 04-12-2011, 09:07 AM
Super Moderator

 

Join Date: Jul 2008
Location: Orangevale, CA
Posts: 11,238
Thanks: 8
Thanked 76 Times in 70 Posts
Feedback Score: 0 reviews
What controller? Is there a setup procedure? Is the P-n-P Harness is for the Ford?
Are you using the 7-pin plug for the trailer?
Have you pulled this trailer before with a controller?
Reply With Quote Quick reply to this message
  #6  
Old 04-12-2011, 09:09 AM
Illiana Chapter Director

 

Join Date: Feb 2008
Location: Bloomington, IN.
Posts: 12,334
Thanks: 5
Thanked 85 Times in 80 Posts
Feedback Score: 2 reviews
Quote:
Originally Posted by RHFDpowerstroke53 View Post
Well i bought the harness from autozone with the connector to the brake controller and the Ford plug. It plugged right in.
Ok, so the wiring coming out of the controller had a plug on it and it plugged directly into the harness you purchased and the harness plugged directly into the factory connector? Sorry for kinda the same question, just wanting to clarify.
Reply With Quote Quick reply to this message
  #7  
Old 04-12-2011, 09:15 AM
Compression Ignition Addict
 

Join Date: Nov 2009
Posts: 213
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
yes its just a ford PnP harness. I have pulled the trailer before but i had to unhook my controller so the breaks wouldnt lock up. The trailer isnt mine. Im not sure what controller it is. Im in class now but ill look when i can. 7PIN connector to the trailer too. It works fine until i turn my lights on and then it shuts off. I have a feeling the harness may be wired incorrectly and the wires are not matching up correctly. I bought stupid autozone junk because i was in a pinch. not its biting me in the a$$
Reply With Quote Quick reply to this message
  #8  
Old 04-12-2011, 09:19 AM
Illiana Chapter Director

 

Join Date: Feb 2008
Location: Bloomington, IN.
Posts: 12,334
Thanks: 5
Thanked 85 Times in 80 Posts
Feedback Score: 2 reviews
Quote:
Originally Posted by RHFDpowerstroke53 View Post
yes its just a ford PnP harness. I have pulled the trailer before but i had to unhook my controller so the breaks wouldnt lock up. The trailer isnt mine. Im not sure what controller it is. Im in class now but ill look when i can. 7PIN connector to the trailer too. It works fine until i turn my lights on and then it shuts off. I have a feeling the harness may be wired incorrectly and the wires are not matching up correctly. I bought stupid autozone junk because i was in a pinch. not its biting me in the a$$
I say the trailer is wired wrong. It may be wired to work for the truck of the guy that owns the trailer but something doesn't sound right. If your harness and controller are completely plug and play then it shouldn't be the problem unless there is more than one harness and you got the wrong one.
Reply With Quote Quick reply to this message
  #9  
Old 04-12-2011, 09:22 AM
Compression Ignition Addict
 

Join Date: Nov 2009
Posts: 213
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
that could be too. he towed it with his chevy 2500 and he has a chevy 5ton too. I dont know why the controller would shut off when i turn my lights on tho
Reply With Quote Quick reply to this message
  #10  
Old 04-12-2011, 09:24 AM
Super Moderator

 

Join Date: Jul 2008
Location: Orangevale, CA
Posts: 11,238
Thanks: 8
Thanked 76 Times in 70 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by dhanna6powerstroke View Post
I say the trailer is wired wrong. It may be wired to work for the truck of the guy that owns the trailer but something doesn't sound right. If your harness and controller are completely plug and play then it shouldn't be the problem unless there is more than one harness and you got the wrong one.
That's what I'm thinking too!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:27 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors