Electrical issue...stumped?? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-23-2011, 02:32 PM
Member
 

Join Date: Feb 2011
Location: Cape Cod, MA
Posts: 61
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Electrical issue...stumped??

I just bought a used 99 f250 psd. Was told by the previous owner that the wipers were stuck on so she pulled the relay brought it to a dealer and was told she needed a new gem module. Ok I just replaced it and guess what. It don't work. I'm clueless. I have the washer pump coming on when I turn the wipers on but no wipers at all. It's snowing and late so I will check voltage at places tomorrow.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-23-2011, 02:57 PM
Premium Member

 

Join Date: Nov 2010
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Sounds like the wiper switch on the steering column is bad. Contacts for washer pump could have shorted together while wiper position switch has open. I would start by checking for power at wiper motor with wiper switch on first though. Should be a simple diagnosis.
Reply With Quote Quick reply to this message
  #3  
Old 03-23-2011, 03:07 PM
Member
 

Join Date: Feb 2011
Location: Cape Cod, MA
Posts: 61
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ya but if I have power there or not I still have an issue with the washer staying on. How hard is it to check the switch
Reply With Quote Quick reply to this message
  #4  
Old 03-23-2011, 03:25 PM
Premium Member

 

Join Date: Nov 2010
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
True. My thinking was that it is possible that the motor could also be bad. If you have power at motor? This would be a simple check. Your switch would be the prime suspect. As for checking the switch..... When I get home(if) I will look at the schematic for you. Unfortunately I am stuck at philly airport waiting to get back to ga. Will be tomorrow before I can look it up.
Reply With Quote Quick reply to this message
  #5  
Old 03-23-2011, 03:29 PM
Premium Member

 

Join Date: Nov 2010
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Btw... I highly recommend this resource. I have it on all our vehicles. ALLDATAdiy.com :: Leading Source of Diagnostic and Repair Information
Reply With Quote Quick reply to this message
  #6  
Old 03-23-2011, 06:51 PM
Compression Ignition Addict
 

Join Date: Apr 2007
Location: Wright City, MO
Posts: 2,709
Thanks: 3
Thanked 4 Times in 4 Posts
Feedback Score: 1 reviews
You probably need a new multifunction switch. They go out all the time.
Reply With Quote Quick reply to this message
  #7  
Old 03-29-2011, 02:17 PM
Member
 

Join Date: Feb 2011
Location: Cape Cod, MA
Posts: 61
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Finally fixed my wiper problem!!! Marcotte ford in ma sucks. They said it was the GEM module that I spent $400 on. Well they were wrong all it were was the multi function switch that cost me $40. Easy fix just wish I hadn't listened to the dealer.
Reply With Quote Quick reply to this message
  #8  
Old 03-30-2011, 04:12 AM
Premium Member

 

Join Date: Nov 2010
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Glad to hear that! Hate that the dealer screwed you though. They make a good living that way. hard to trust mechanics sometimes when they are gettin' paid.

Lesson learned. We appreciate the update. Will keep someone else from getting the shaft.
Reply With Quote Quick reply to this message
  #9  
Old 03-30-2011, 04:15 AM
Premium Member

 

Join Date: Nov 2010
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
BTW.... if you still have your original GEM model you may be able to advertise it for sale. Maybe then at least you can recoup some of you money.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:38 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors