03 F-250 ELECTRICAL PROBLEM - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 01-16-2011, 08:31 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jan 2011
Location: Buchanan Co Iowa
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Question 03 F-250 ELECTRICAL PROBLEM

I have no power to the radio and power windows. Happend last fall and started working again a few short days later, its back again! I hve no juice on the feed side of the fuse as u probably no, I would like some help on were 2 start next, hope that somone has experince this before. Thanks guys
barlow is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 01-17-2011, 06:55 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jan 2011
Location: Buchanan Co Iowa
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Question

bump bump bump
barlow is offline  
post #3 of 5 Old 01-17-2011, 02:56 PM
Member
 
Join Date: Feb 2010
Posts: 74
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Electrical

There is a module by the glove box that all those things plug into. It might be the GEM module. It is what tells the radio to stay on until the door opens and such. It gets wet sometimes from a windshield leak and goes bad. You can see it if you take the glove box out and look up to the right. It is hard to get to the one screw that holds it in toward the front of the module. Take it out and see if you see any water damage on the inside of the plastic. You can unclip the plastic from the circuit board.

Hope this helps.
pablito is offline  
post #4 of 5 Old 01-19-2011, 06:50 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jan 2011
Location: Buchanan Co Iowa
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Thank you pablito, I will give this a shot. Would not have guessed this, great web site here!
barlow is offline  
post #5 of 5 Old 05-09-2012, 07:27 AM
Powerstroke.org Rookie
 
Join Date: Apr 2012
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Same problem

I'm having a similair problem in my 03 F250, What did you find out when you looked at that unit? I'm at the beginning of this process and a newb to these trucks too, so I'm trying not to chase my tail for too long.
DonC is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome