Questions about boost and exhaust temp. - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-06-2010, 02:41 PM
Member
 

Join Date: Aug 2010
Posts: 52
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Question Questions about boost and exhaust temp.

I have an '01...7.3 auto.DDP stage1 inj. Garret 38r,Banks intercooler and 5" exh.Waiting for my PHP chip so I'm running the SCT that came with the truck.None of the gauges were working when I got the truck.I now have boost,exh. temp and tranny temp. I was told the boost was 25 but I've never seen more than 15!? Exh. temp will climb to 1200 on moderate acceleration with no load! I didn't expect this high an exh. temp just driving around!? Is this normal?? This truck does have a smoke issue with the SCT but not as bad with the PHP. I thought the bigger turbo would drop the temps?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-06-2010, 10:43 PM
Banned
 

Join Date: Oct 2009
Location: Riverside/Norco, Ca
Posts: 3,771
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 2 reviews
Wow it sounds like you have a massive boost leak. Or that SCT is way screwed up big time. You need to have the PCM programmed for the turbo and injectors for sure though.. but to make sure you dont have a leak(sounds like you may with only 15 psi and way too high egts) check your uppipes and all your IC boots to make sure they arent leaking. Uppipe donut gaskets are notorious.
Reply With Quote Quick reply to this message
  #3  
Old 12-07-2010, 06:02 AM
Compression Ignition Addict
 

Join Date: Jan 2009
Location: Harrisville UT
Posts: 556
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
You need custom tunes to run those injectors and like said earlier, you have a boost leak. Check your uppipes and IC boots, you should be able to make 30lbs of boost or more.
Reply With Quote Quick reply to this message
  #4  
Old 12-07-2010, 02:34 PM
Member
 

Join Date: Aug 2010
Posts: 52
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks guys.I checked for boost leaks....none,but I did find something.I have a boost control that I was told was set for 25 psi.so I didn't want to fool with it.Just gave it a couple of clicks and went from 15 max to 25.One more click and I now have 30psi!!!Big improvement. Just waiting on my PHP chip!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:21 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors