Am I blind? - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 11-23-2010, 10:03 PM Thread Starter
Tom Hartz's Avatar
Join Date: Sep 2010
Location: Santa Clarita, Ca.
Posts: 40
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Am I blind?

Ok don't laugh, do all 2002 PSD have a block heater? My 95 did and I can not find it on my 02.


Tom Hartz is offline  
Sponsored Links
post #2 of 2 Old 11-24-2010, 06:59 AM
Compression Ignition Addict
Join Date: Dec 2007
Posts: 5,817
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
Thanks: 5
Thanked 185 Times in 175 Posts
Feedback Score: 3 reviews
Should be there, maybe the cord was removed from the block?

Look above the oil filter, that's where the AC cord plugs-in to the engine, and see if you either have a cord OR follow it forward to where it's hiding
NoRalPh is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome