Power mirror??? ^##$%^^&!!! - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-11-2010, 07:28 PM
Compression Ignition Addict
 

Join Date: Nov 2007
Location: Palmer Alaska
Posts: 683
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Power mirror??? ^##$%^^&!!!

Okay boys it don’t happen often but I’m stumped! Looked all over and can’t find any info so thought I’d ask before I break something. Got an 01 Excursion with the towing mirrors and the passenger side won’t power adjust. The little motor will buzz in there but nothing moves, its something I’m 95% sure I can fix but I can’t get at it.

So has anybody figured out how to open up the housing on these things? I see some bolt heads behind the glass. Maybe I can get a socket on them with a flex extinction but that’s a maybe, or maybe a ľ drive metric wobble socket, neither of which I have but can get. I have a bunch of assorted good wobble extensions but they are too long and a no go. I tried to unsnap the front and back plastic and got it gapped maybe 3/8 wide but it just feels like it’s bolted from the inside. I’m thinking maybe the glass snaps out somehow but I don’t see any way and don’t want to break it!

Looked on the web for hours and find nutin! So does someone know or am I just on my own? HELP!!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-13-2010, 10:27 AM
Compression Ignition Addict
 

Join Date: Nov 2007
Location: Palmer Alaska
Posts: 683
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Nobody has been inside a mirror?

Well maybe I should take pictures and post it up when I figure it out . . . if I donít bust it anyway.
Reply With Quote Quick reply to this message
  #3  
Old 11-13-2010, 11:36 AM
Banned
 

Join Date: Oct 2006
Location: Bend, Or
Posts: 6,091
Thanks: 29
Thanked 39 Times in 37 Posts
Feedback Score: 0 reviews
Its not the mirror... Its the switch. Always is.

Pull the switch out, carefully take it apart and clean the contacts.

The issue is water and crap gets into the switch and it quits working.
Reply With Quote Quick reply to this message
  #4  
Old 11-13-2010, 07:40 PM
Member
 

Join Date: Mar 2010
Location: Newport,WA
Posts: 49
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
what CSIPSD said. It worked for me and several others.
Reply With Quote Quick reply to this message
  #5  
Old 11-13-2010, 08:24 PM
Compression Ignition Addict
 

Join Date: Nov 2007
Location: Palmer Alaska
Posts: 683
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
So, I may have something new then and on my own. I'll check the switch but I'm sure it's fine, the motor is buzzing away in there when I hit it . . . get no up/down or left/right just the same sound like the other side. Also I can see the little arm that hooks the motor to the glass and it looks to be dangling inside there.
Reply With Quote Quick reply to this message
  #6  
Old 11-13-2010, 08:43 PM
Compression Ignition Addict
 

Join Date: Jul 2009
Location: Savannah,Ga
Posts: 2,800
Thanks: 4
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by CSIPSD View Post
Its not the mirror... Its the switch. Always is.

Pull the switch out, carefully take it apart and clean the contacts.

The issue is water and crap gets into the switch and it quits working.
I think my problem is the switch. Mine will go up and left but not down and right. You think that is the switch and will cleaning the contacts fix it you think?
Reply With Quote Quick reply to this message
  #7  
Old 11-13-2010, 09:05 PM
Compression Ignition Addict
 

Join Date: Nov 2007
Location: Palmer Alaska
Posts: 683
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Okay boys she be NOT the switch!
I popped the switch out and put the one from my F350 in there and same thing.
Put this switch in the F350 and it works just fine.
From this I conclude the switch from the Excursion is fine and in fact just left it in the F350.

So I guess nobody has opened one of these up and Iím on my own so I will take pix and explain what I find in there . . . wish me luck!
Reply With Quote Quick reply to this message
  #8  
Old 11-13-2010, 09:12 PM
Compression Ignition Addict
 

Join Date: Nov 2007
Location: Palmer Alaska
Posts: 683
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Mikey's250 View Post
I think my problem is the switch. Mine will go up and left but not down and right. You think that is the switch and will cleaning the contacts fix it you think?
Sounds likely to me. I popped mine open to see whatís in there. Took me a bit to realize the white tabs that look like they hold it together donít. There are 4 black tabs holding it and little slots for a small screw driver to pry it open with. Go slow and work over a tray . . . I dropped the clear rocker linkage and lost a tiny plastic rod out of it for a bit.
Reply With Quote Quick reply to this message
  #9  
Old 11-14-2010, 06:51 AM
Banned
 

Join Date: Oct 2006
Location: Bend, Or
Posts: 6,091
Thanks: 29
Thanked 39 Times in 37 Posts
Feedback Score: 0 reviews
I've never had one where the mirror was the issue...

I would use a test light and check the wires on that side before I would tear into the mirror...
Reply With Quote Quick reply to this message
  #10  
Old 11-14-2010, 08:20 AM
Compression Ignition Addict
 

Join Date: Nov 2009
Location: Central Delaware
Posts: 164
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Its really simple...Ive had this issue. There is 2 (I think) little white pins with a tiny ball on the end of them. That ball pops into small tabs on the back of the mirror. If you pry the glass off then pull the white tabs from the mirror base. Then snap the ball ends onto the glass. So now you have glass with both white pins hanging off the back of the glass. Now align them into the motor holes and push the whole glass straight in until it pops on. These little white pins should have a little tab on the ball end so they dont just rotate in the socket. If that has broken off then your just spinning them and not moving the mirror. If that all make sense to you.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:47 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors