turbo issue help? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-22-2010, 06:36 AM
Compression Ignition Addict
 

Join Date: Oct 2009
Location: East Tennessee
Posts: 379
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
turbo issue help?

Hey guys! I haven't been on here in awhile...been very busy.

Since I've been on here my truck has changed alot but i now have an issue with its running. It started about a week ago when i put a new chip on it...TS 6 Position.

On acceleration(light or hard) it suddenly loses boost..bad. Like it can be pushing 25lbs and just drop to 5 automatically. I've checked and fixed any boots and its continuing to do it. Any ideas?
It's a early 99 f250 7.3
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 10-22-2010, 06:48 AM
DJM DJM is offline
Compression Ignition Addict
 

Join Date: Sep 2005
Location: Springfield ,OR
Posts: 794
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
A long shot but have heard of it happening before but check the housing bolts on the turbo have heard of them comin loose or even comin all the way out.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:52 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors