Vent Help - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-01-2010, 02:22 AM
Powerstroke.org Fanatic
 

Join Date: Aug 2010
Location: Knox,IN
Posts: 105
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Vent Help

Just bought a new truck and haven't looked into it yet but the airflow when the turned to the vents seems very low. Plenty of airflow to the defrost and floor. Is this a normal thing for 7.3's. If not is there any places I should check first.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 09-01-2010, 02:29 AM
Banned

 

Join Date: Jul 2008
Location: Bryan/College Station/Tyler, TEXAS
Posts: 26,488
Thanks: 15
Thanked 10 Times in 9 Posts
Feedback Score: 1 reviews
first. when on vent, do you feel any air on the floor or defrost? and make sure the air flow wheel on the left side of the vent is set to open.
Reply With Quote Quick reply to this message
  #3  
Old 09-01-2010, 03:50 AM
Powerstroke.org Fanatic
 

Join Date: Aug 2010
Location: Knox,IN
Posts: 105
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
All flow vents are set to open and there is not airflow to anywhere besides the vents when the dial is turned to the vents.
Reply With Quote Quick reply to this message
  #4  
Old 09-02-2010, 04:32 PM
Banned
 

Join Date: Oct 2009
Location: Riverside/Norco, Ca
Posts: 3,771
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 2 reviews
might be time for a new vacuum pump.
Reply With Quote Quick reply to this message
  #5  
Old 09-02-2010, 04:36 PM
Powerstroke.org Fanatic
 

Join Date: Aug 2010
Location: Knox,IN
Posts: 105
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I was hoping you werent gonna say that.
Reply With Quote Quick reply to this message
  #6  
Old 09-02-2010, 04:36 PM
Banned

 

Join Date: Jul 2008
Location: Bryan/College Station/Tyler, TEXAS
Posts: 26,488
Thanks: 15
Thanked 10 Times in 9 Posts
Feedback Score: 1 reviews
how would it be a vac pump when you only feel air from the vents and no air from defrost and floor like it was stuck in half mode. i doubt these have cabin air filters and i dont think theres a screen from the blower that could block air flow.
Reply With Quote Quick reply to this message
  #7  
Old 09-02-2010, 04:41 PM
Powerstroke.org Fanatic
 

Join Date: Aug 2010
Location: Knox,IN
Posts: 105
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No the defrost and floor work as well just minimal airflow. Maybe the blower motor is on its way out.
Reply With Quote Quick reply to this message
  #8  
Old 10-26-2010, 05:47 PM
Powerstroke.org Fanatic
 

Join Date: Aug 2010
Location: Knox,IN
Posts: 105
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ok so update to this. I have installed a new vacuum pump and a new blower motor. Still poor airflow out of the floor, the defrost and the vents. Any other ideas?
Reply With Quote Quick reply to this message
  #9  
Old 10-26-2010, 06:28 PM
Banned

 

Join Date: Jul 2008
Location: Bryan/College Station/Tyler, TEXAS
Posts: 26,488
Thanks: 15
Thanked 10 Times in 9 Posts
Feedback Score: 1 reviews
Quote:
Originally Posted by sinnful_46534 View Post
No the defrost and floor work as well just minimal airflow. Maybe the blower motor is on its way out.
so 2 months later i reread the posts and i dont know why i kept sayin no air from floor and defrost sorry about that.

Quote:
Originally Posted by sinnful_46534 View Post
Ok so update to this. I have installed a new vacuum pump and a new blower motor. Still poor airflow out of the floor, the defrost and the vents. Any other ideas?
all vents are open? all tubing to vents are connected? no blockage anywhere? vent door is opening? vac line to vent door works?
Reply With Quote Quick reply to this message
  #10  
Old 10-26-2010, 06:42 PM
Powerstroke.org Fanatic
 

Join Date: Aug 2010
Location: Knox,IN
Posts: 105
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No worries at all my friend. Yes all vents are open and all tubes are connected. I have not noticed a blockage anywhere. My next plan of attack I guess is to check vent door and remove heater core to see if there is a blockage there. Does this seem like the next things in line to check?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:52 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors