EGTs very high quickly - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-26-2010, 09:30 AM
Compression Ignition Addict
 

Join Date: Nov 2009
Posts: 567
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to F250 Fever
EGTs very high quickly

So my EGTs get high very quickly.... I don't have my php installed currently due normal issues not phps fault at all so my truck is stock other than my mods jus no chip, my cruising temps in my truck sit around 800 mostly all the time and a. Head wind its hits about 900 and jus getting on it a bit it will very very easily hit 1000-1200 no problem.... I have not really checked for boost leaks since my truck hits 17lbs of boost stock, I jus don't understand how my truck hits these temps?? I have a 4in exhaust and a cone style KnN intale not the box filter so I really don't understand what I'm missing here guys? The temps here in utah have been about 95 to 100 but I should not be hitting these number especially with no chip.... any help is greatly appreciated.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-26-2010, 10:01 AM
Compression Ignition Addict
 

Join Date: Jun 2009
Location: Asheville, NC
Posts: 439
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Man it's just hot everywhere right now. So, you may have already answered your question especially regarding the temps where you live. It's just hot everywhere, for sure. We are hitting around the high 80's to low 90's where I live and it doesn't take long for me to get up to around the same EGT's that you have. And this is also just running in stock mode.

How soon can you re-install the PHP? A good custom tuned chip could help........ (truck sustains cruising speeds easier and with less effort).

Also, are you running a CAI of any kind?
Reply With Quote Quick reply to this message
  #3  
Old 07-26-2010, 10:12 AM
Member
 

Join Date: Mar 2010
Location: phoenix
Posts: 79
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Skype™ to 1BAD99
that sounds pretty hot to me pretty fast man. Im in phoenix so im in prob just the same heat as you if not hotter and if im pushing the pedal pretty hard im only seeing around 9ish on the egt's. I wish i could be more help as to what the problem may be. I'd get the chip back on there and see if that doesn't make a difference. Could be a fuel/timing issue that the chip might be able to correct for.
Reply With Quote Quick reply to this message
  #4  
Old 07-26-2010, 10:13 AM
Compression Ignition Addict
 

Join Date: Nov 2009
Posts: 567
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to F250 Fever
The thing is guys its even worse when my chip is on my truck in the 80hp daily driver....
Reply With Quote Quick reply to this message
  #5  
Old 07-26-2010, 10:20 AM
Compression Ignition Addict
 

Join Date: Nov 2009
Posts: 567
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to F250 Fever
Oh and my dad has the same truck as me with no mods at all and the stupid edge and his EGTs are tits!!
Reply With Quote Quick reply to this message
  #6  
Old 07-27-2010, 02:17 PM
Compression Ignition Addict
 

Join Date: Nov 2009
Posts: 567
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to F250 Fever
Anybody else have any ideas? My boost spikes at 17lbs so I'm assuming no boost leak and I jus recently cleaned my intake.....
Reply With Quote Quick reply to this message
  #7  
Old 07-27-2010, 02:34 PM
Serving Our Country!
 

Join Date: Jul 2008
Location: AMERICA
Posts: 529
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
my truck runs that hot also.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:00 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors