Turbo rebuild with broken/missing bolts on the turbo - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 05-20-2010, 08:33 AM Thread Starter
Powerstroke.org Fanatic
skullsniper's Avatar
Join Date: Feb 2010
Location: Fritch TX
Posts: 94
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Turbo rebuild with broken/missing bolts on the turbo

I took my turbo out last night to rebuild it and found 1 broken bolt, 1 missing bolt and 1 loose bolt where the exhaust side of the turbo bolts to the pedistal mount of the turbo. What would cause this and what kind of locktite should I use to keep this from happening again? I guess I get to have a hot date with a easy out and the drill press tonight.
skullsniper is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome