led lighting issues - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-27-2010, 10:01 AM
Powerstroke.org Fanatic
 

Join Date: Sep 2009
Location: Amherst, NY and Alfred, NY
Posts: 111
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
led lighting issues

I just bought new LED Trucklight stop turn tails for my truck. They are the standard oval lights that would be used on trailers. The passanger side works fine, but the driver side turn signals and stop lamps arnt working. The driver side running lights work fine too. Whenever i put my regular incandescent lights back in, everything works just fine. Any ideas guys?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-27-2010, 10:12 AM
Premium Member


 

Join Date: Feb 2006
Location: Sacramento
Posts: 8,008
Thanks: 15
Thanked 90 Times in 74 Posts
Feedback Score: 3 reviews
I think there's a resistor you need to install in order for LEDs to work correctly. Since they don't draw as much current as your standard bulbs, the truck's electrical system thinks the bulb is burnt out.
Reply With Quote Quick reply to this message
  #3  
Old 04-27-2010, 10:43 AM
Compression Ignition Addict
 

Join Date: Mar 2008
Location: Santa Rosa, CA
Posts: 1,342
Thanks: 0
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
Did you try swapping the led lights from side to side so that you can find out if the problem is the truck or the led?

Always check the easy things first


I run oval leds in my taillight housings with no problems, just had to change out my flasher for an electronic one so the turn signals would flash at the correct speed.
Reply With Quote Quick reply to this message
  #4  
Old 04-27-2010, 11:39 AM
Powerstroke.org Fanatic
 

Join Date: Sep 2009
Location: Amherst, NY and Alfred, NY
Posts: 111
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
yes i tried switching side to side, but the driver stop and turn lights still wouldn't work. i was thinking it could be a ground issue? i still confused as to why the regular incandescent bulbs work fine and the led do not. I understand that the flashers will be faster, but that isn't the issue. thanks again
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:21 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors