Cruise Control Problems - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-01-2007, 04:22 PM
Member
 

Join Date: Apr 2007
Location: Lapeer, Michigan
Posts: 71
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Cruise Control Problems

My cruise quit working, I checked the fuses and they are fine. Everything else works fine. Anybody have any ideas.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 05-01-2007, 04:24 PM
duct tape & zip ties

 

Join Date: Jul 2006
Location: Willis, MI
Posts: 10,759
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to bigcountrysg
Quote:
Originally Posted by tosch88 View Post
My cruise quit working, I checked the fuses and they are fine. Everything else works fine. Anybody have any ideas.
How about the switches or wiring in the steering column. Bring it over and lets take a looky ok.

By the way welcome to the site.
Reply With Quote Quick reply to this message
  #3  
Old 05-01-2007, 06:16 PM
Strokin' In Dixie-Land
 

Join Date: Jan 2007
Location: Troy, Alabama
Posts: 2,393
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
to THE site!!!!
Reply With Quote Quick reply to this message
  #4  
Old 05-01-2007, 06:34 PM
Compression Ignition Addict
 

Join Date: Dec 2006
Location: Lincoln NE
Posts: 201
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ive had to replace the sensor on the master cylinder on mine to get the cruise working right.
Reply With Quote Quick reply to this message
  #5  
Old 05-01-2007, 06:39 PM
Emergency Services
 

Join Date: Oct 2006
Location: tampa, florida
Posts: 1,071
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
does the horn work?.?.its on the same circuit
Reply With Quote Quick reply to this message
  #6  
Old 05-01-2007, 07:27 PM
Compression Ignition Addict
 

Join Date: Nov 2005
Location: Big Cypress Indian Reservation
Posts: 2,756
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
If the horn isnt working either then it is your clock spring. If the horn is workin youve got other problems
Reply With Quote Quick reply to this message
  #7  
Old 05-01-2007, 07:48 PM
HardLuck Case of the Year
 

Join Date: Sep 2006
Location: Catonsville, MD
Posts: 3,541
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to Ditty Send a message via Yahoo to Ditty
I've had a little problem with mine since I bought it. I have to push the button ON button pretty hard at the VERY top of the button...after that all is well. Just something for you to check.
Reply With Quote Quick reply to this message
  #8  
Old 05-03-2007, 01:55 PM
Member
 

Join Date: Apr 2007
Location: Lapeer, Michigan
Posts: 71
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Horn works fine, I've got a bad feeling there are some chaffed wires. The guy that owned this truck before me was a little rough on her off the highway.Great site,I did the intake mod that Maintain posted seemed to help. I will pull the switch off and test it. Thanks guys, I"ll keep you posted.
Reply With Quote Quick reply to this message
  #9  
Old 05-03-2007, 03:34 PM
Compression Ignition Addict
 

Join Date: Apr 2007
Location: lewiston, Id.
Posts: 5,008
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
use you foot to pull the emergency brake pedal all the way up... that was the problem with mine! the parking brake sensor wont allow you to use cruise if it reads that the brake is engaged even a little bit!
Reply With Quote Quick reply to this message
  #10  
Old 05-04-2007, 12:15 PM
Powerstroke.org Rookie
 

Join Date: May 2007
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
My CC works when it wants to!!! I dont know why . I have tryed what poeple have posted. But with no luck . If I am under about 40mph It works good, above that it turns off all the time.




2003 F350 6speed 6.0L
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:54 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors