HPOP seal blew while towing... - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-13-2010, 01:16 PM
Powerstroke.org Rookie
 

Join Date: Aug 2009
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
HPOP seal blew while towing...

Yesterday the HPOP seal on my 01 F250 blew while towing the RV. I didn't notice the oil pressure gauge drop, but the oil level was off the bottom of the dipstick and the truck would not run at all. Once I fsaw the huge puddle of oil I had a pretty good idea of what happened so I poured a quart of oil into the truck and was able to get it started and moved a few hundred yards to a safe place on the shoulder.

Here's the question; if I've run the oil so low that the HPOP cannot provide pressure to the injectors, have I also run it so low that the lubrication system stopped pumping oil to other vital parts of the engine? Or is the HPOP pick-up positioned so that it will stop running the injectors before the oil level gets too low for the lubrication system?

Right now the work is being done under warranty, so if there's other work that needs to be addressed because of this failure I'd like to have that done now, and not on my dime.

Last edited by homerj; 04-15-2010 at 11:07 AM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-15-2010, 11:07 AM
Powerstroke.org Rookie
 

Join Date: Aug 2009
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
The dealership reports it was definitely the HPOP, and that it wouldn't have caused more damage to the motor.
Reply With Quote Quick reply to this message
  #3  
Old 04-15-2010, 04:35 PM
Banned
 

Join Date: Oct 2009
Location: Riverside/Norco, Ca
Posts: 3,771
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 2 reviews
Thats the cool thing about heui injection systems.. if you run outta oil they stop before it really damages the engine..
Reply With Quote Quick reply to this message
  #4  
Old 04-17-2010, 06:42 AM
Member
 

Join Date: Feb 2010
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Happened to me last week. My thread is in here somewhere.

My truck is back to running right now and no known problems.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:07 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors