Help truck wont start - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-08-2010, 11:10 AM
Compression Ignition Addict
 

Join Date: Dec 2009
Posts: 186
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Help truck wont start

Well yesterday I went out and drove it like normal.... It was running just fine. Got back to my girlfriends house and shut it down. The only thing I did different then normal was put the emergency brake on. I started to do this because the other day I thought I put it into park and I got out and it rolled into the grass a few feet. I went out this afternoon to go home and I put the key into the ignition went to the glow plugs and waited for the light to go out like normal. Then turned the key all the way and nothing. No cranking no noise nothing. I double checked the shift lever. Tried starting in park and neutral and while moving the lever around and nothing. Never made any noise at all. No cranking nothing. Battery is good just had it checked and everything works great in the truck just wont start.

What should I do?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-08-2010, 11:12 AM
Compression Ignition Addict
 

Join Date: Oct 2007
Location: Pasadena, TX
Posts: 6,512
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
see if you have power to the starter relay and go from there
Reply With Quote Quick reply to this message
  #3  
Old 04-08-2010, 01:17 PM
Compression Ignition Addict
 

Join Date: Dec 2009
Posts: 186
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Quote:
Originally Posted by symbols View Post
see if you have power to the starter relay and go from there
Nope did not have it... I just bridged it and it started up. Thanks you nailed it on the head!
Reply With Quote Quick reply to this message
  #4  
Old 04-09-2010, 05:43 AM
Compression Ignition Addict
 

Join Date: Oct 2007
Location: Pasadena, TX
Posts: 6,512
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Wickky View Post
Nope did not have it... I just bridged it and it started up. Thanks you nailed it on the head!
Ok so then it's most likely a fuse or your ignition switch. Have you tracked it down yet?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:24 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors