Everything just died. Need help - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-31-2010, 05:25 AM
Compression Ignition Addict
 

Join Date: Jul 2009
Location: Savannah,Ga
Posts: 2,760
Thanks: 3
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Everything just died. Need help

I need some help before I go tearing stuff apart.

Ok I drove like 3 mins to class, I rolled the window down and listened to the radio. Well when I park and shut off the truck everything went off instead of the normal 10 min period when the radio stays on and the windows still work. So I turn the key backwards to roll up my window and it does nothing, the radio wasnt coming on either. I turn the key forward and it still does nothing the gauges didnt move, no wait to start light nothing. I started truck with no problem and drove back home with no windows radio or gauges. The switch that adjust the mirrors and door locks work. The over head display and heater/air works.

What is going on? Is this just a fuse or something more serious???

Help me out fellas
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-31-2010, 05:36 AM
Compression Ignition Addict
 

Join Date: Jul 2008
Location: harlingen tx
Posts: 1,139
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
have you checked your fuses?
Reply With Quote Quick reply to this message
  #3  
Old 03-31-2010, 05:37 AM
Compression Ignition Addict
 

Join Date: Jun 2008
Location: Hadley, Michigan/Lima, Ohio
Posts: 3,070
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to thesmokinstroke02
mine will do the same thing but it quits after i let it sit for a few minute.
Reply With Quote Quick reply to this message
  #4  
Old 03-31-2010, 05:40 AM
Compression Ignition Addict
 

Join Date: Jul 2009
Location: Savannah,Ga
Posts: 2,760
Thanks: 3
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Quote:
Originally Posted by baddkarmaracing View Post
have you checked your fuses?
Im about to go do that. I hate electical stuff so bad.


Quote:
Originally Posted by thesmokinstroke02 View Post
mine will do the same thing but it quits after i let it sit for a few minute.
How often does it do it? Cause this has never happened. It sat for about 5 mins while I griped to my buddy about it haha but still nothing
Reply With Quote Quick reply to this message
  #5  
Old 03-31-2010, 05:43 AM
Compression Ignition Addict
 

Join Date: Jun 2008
Location: Hadley, Michigan/Lima, Ohio
Posts: 3,070
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to thesmokinstroke02
once in a blue moon lol. i probably have a short somewhere. most of my electrical on my doors has got wet at one point in time lol.
Reply With Quote Quick reply to this message
  #6  
Old 03-31-2010, 05:47 AM
Compression Ignition Addict
 

Join Date: Jul 2008
Location: harlingen tx
Posts: 1,139
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
if its not a fuse i would asume the gem is bad or going bad
Reply With Quote Quick reply to this message
  #7  
Old 03-31-2010, 05:48 AM
Compression Ignition Addict
 

Join Date: Jun 2008
Location: Hadley, Michigan/Lima, Ohio
Posts: 3,070
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to thesmokinstroke02
gem?
Reply With Quote Quick reply to this message
  #8  
Old 03-31-2010, 05:52 AM
Compression Ignition Addict
 

Join Date: Jul 2008
Location: harlingen tx
Posts: 1,139
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
General Electronics Module it controls most of the electronics in the truck
Reply With Quote Quick reply to this message
  #9  
Old 03-31-2010, 05:54 AM
Compression Ignition Addict
 

Join Date: Jun 2008
Location: Hadley, Michigan/Lima, Ohio
Posts: 3,070
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to thesmokinstroke02
oh gotcha. ya learn somethin new every day .
Reply With Quote Quick reply to this message
  #10  
Old 03-31-2010, 06:17 AM
Compression Ignition Addict
 

Join Date: Jul 2009
Location: Savannah,Ga
Posts: 2,760
Thanks: 3
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Quote:
Originally Posted by baddkarmaracing View Post
General Electronics Module it controls most of the electronics in the truck
Ok tell me this. In regards to the GEM, can and alarm/remote start that is not hooked up properly cause this failure?

I have been fightin with the audio place because they can not get my remote start to work and they already fried an alternator so if they caused this Im gonna have a fit
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:08 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors