Issues after gaskets/ glowplugs - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-06-2010, 03:50 PM
Compression Ignition Addict
 

Join Date: Jul 2009
Posts: 171
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Issues after gaskets/ glowplugs

Ok, dont beat me down to badly, I need help!

Diagnosed my oil leak from previous post's last week to be back side of valve cover gasket on pass. side. Figured while I was at it Id replace glow plugs too. Had some rough starts and stalling this winter so I know it needed it. Anyway, after getting my blood pressure back to normal from seeing the prices on these valve cover gaskets from both Ford and International, I opted to go with the "good deal" gaskets from Full Service. There Dorman brand and have the interior and exterior harnesses included for $81.00 each.

Did the install today, plugged everything in inside, put the covers back on, (DID NOT USE THE EXTERIOR HARNESS PLUGS. IT HAD NOTES ON A PAPER FOR WHAT DORMAN WIRES MATCHED THE FORD OE WIRES BUT DID NOT WANT TO CUT INTO THEM.)and put it all back together. Upon starting, I immeidately got a check engine light and rough idle. I drove it down the street and the higher I put the DP tuner up to the worse it ran. Think I need to use there plugs? The old plugs snapped right into the new gaskets.....could the wiring be different?? Im kicking myself now for going the cheaper way out. If these are bad im going to make that salesman at Full service eat them!!

Do I need to put the other plugs on to make it run right?
Please help!!
Thanks!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-06-2010, 06:48 PM
Compression Ignition Addict
 

Join Date: Dec 2009
Posts: 1,283
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Not to sound like a smart a**,do you think you may have mixed the plugs up under the vc and hooked to the wrong injectors,or the new ones may have wrong wiring layout?
Something doesn't sound right to get codes you didn't have before repairs.
Reply With Quote Quick reply to this message
  #3  
Old 03-07-2010, 05:09 AM
Compression Ignition Addict
 

Join Date: Jul 2009
Posts: 171
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
the new harness under the VC is attached in a way that they can only plug into one spot. My question is if I need to wire on the Dorman plug on top in order for these to function properly. I also read that some guys have had issues with the clips holding the wiring to the injectors onthe Dorman set-up not being strong enough for a good connection and having to re-use the clips from the motorcraft gasket. If the rain holds off today I will be tearing back into it.
Reply With Quote Quick reply to this message
  #4  
Old 03-07-2010, 12:03 PM
Compression Ignition Addict
 

Join Date: Jul 2009
Posts: 171
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Tore everything back down this afternoon. Found one injector on the passangers side was un-plugged. Fixed the idle issue and no check engine light.
Bad I had to tear into it again for an oversite like that but good that im getting fast at it....lol less than half yesterdays time!!
Lesson learned to triple check before closing up!!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:32 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors