Big Problems, Need input - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-13-2009, 07:55 PM
Powerstroke.org Rookie
 

Join Date: Nov 2009
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Big Problems, Need input

I have a 99 F350 7.3L. I bought it not running. Instrumnet cluster light lights up like it's in the "run" position when you connect the batteries or one battery. It would turn over but would not start. Removed and replaced the dash wiring harness thinking this is what controled it all. Nothing. Replaced PCM. I finally got it to run. but could not shut it off!!! I pulled the fuel pump relay still ran until I removed the battery cable and about 10 seconds later it will shut off. I know I have a wiring problem but I'm not seeing it. I have inspected all the connectors and can't find anything burnt wires. The next thing I want to try is the Power distribution box that under the hood. What do ya'll think???
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-14-2009, 04:50 AM
Powerstroke Junkie


 

Join Date: Aug 2006
Location: Mayberry, NC
Posts: 8,309
Thanks: 0
Thanked 32 Times in 9 Posts
Feedback Score: 0 reviews
Check the steering column down from the switch is a linkage with two small bolts/screws that can come loose and won't let the key operate correctly.

NCH
Reply With Quote Quick reply to this message
  #3  
Old 12-14-2009, 01:13 PM
Powerstroke.org Rookie
 

Join Date: Nov 2009
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I removed the Instrument Cluster and it started working normally. I guess I'm getting a cluster!
Reply With Quote Quick reply to this message
  #4  
Old 12-14-2009, 01:22 PM
Compression Ignition Addict
 

Join Date: Jul 2008
Location: harlingen tx
Posts: 1,139
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
how much you wanna spend on one? i have a`cluster out of a 99 f350 sittin in my barn
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 07:52 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors