Turbo problem? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-10-2009, 04:37 AM
Compression Ignition Addict
 

Join Date: Mar 2009
Location: CC Indiana
Posts: 187
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Turbo problem?

Since its been cold my truck is doing something weird. I normally let it warm up 15mins. I hear the flapper inside shut and my truck sounds like a airplane. All that is normal.

When I come back outside its normally sitting around 900 RPMs and I hit the brake and it goes down and idle normal.
I start to drive and I normally take it pretty easy on it as its not completely warmed up.

I get to about 1700 - 2,000 RPMs and my truck starts making a swooshing sound. If I hit the gas a little harder it stops.
It even happens when when I have the cruise on going down the highway.

I noticed when I am cruising around 55 MPH with the cruise on my Boost is around 3-4 PSI. When this happens my Boost drops down to 0 or 1 PSI.

Sometimes I am accelerating and my boost is around 8 PSI and it drops to 0 or 1.

Once the truck is completely warmed up it will not do it. By completely warmed up I mean at normal operating temp. Not just in the dummy gauge normal area.

Is this a problem or normal? This is my first diesel in the cold.

Its been around 30 degrees and today it was 8!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-10-2009, 08:54 AM
Banned
 

Join Date: Sep 2008
Location: Fort Bragg, NC/Buff, NY/Midlothian, VA
Posts: 5,630
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
these trucks have a hi-idle for when it's excessively cold. When you tap the brake, put it into gear, or on 6spds release the park brake hi-idle ceases.

The woooshing at 55mph it just the ebpv opening to warm up the oil. Normal again.
Reply With Quote Quick reply to this message
  #3  
Old 12-10-2009, 10:06 AM
Compression Ignition Addict
 

Join Date: Mar 2009
Location: CC Indiana
Posts: 187
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by 85_305 View Post
these trucks have a hi-idle for when it's excessively cold. When you tap the brake, put it into gear, or on 6spds release the park brake hi-idle ceases.

The woooshing at 55mph it just the ebpv opening to warm up the oil. Normal again.
Should my boost drop to zero?


I knew it was normal at idle but i could not find anything about it while moving
Reply With Quote Quick reply to this message
  #4  
Old 12-10-2009, 12:13 PM
Compression Ignition Addict
 

Join Date: Oct 2006
Location: Bend, Or
Posts: 6,089
Thanks: 29
Thanked 38 Times in 36 Posts
Feedback Score: 0 reviews
Completely normal operation.
Reply With Quote Quick reply to this message
  #5  
Old 12-10-2009, 12:24 PM
Compression Ignition Addict
 

Join Date: Mar 2009
Location: CC Indiana
Posts: 187
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks, I figured it was but wanted to be 100%
Reply With Quote Quick reply to this message
  #6  
Old 12-10-2009, 02:14 PM
Compression Ignition Addict
 

Join Date: Nov 2009
Posts: 567
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Send a message via Yahoo to F250 Fever
Quote:
Originally Posted by joshk View Post
Thanks, I figured it was but wanted to be 100%
mine does exactly what you said all the time in cold temps very annoying.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:07 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors