Rough Idle, just a few questions - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 11-18-2009, 06:43 AM Thread Starter
Member
 
Join Date: Jun 2009
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Rough Idle, just a few questions

Yesterday i drove my tuck (auto 144k miles) to work and it drove 100% normal, right before i pulled into work the fuel light came on and i shut the truck off. After work i start the truck back up and its running way different, my first guess was it was just low on fuel so i drive it across the street (not running right) shut it down and fill her up. after she is full i start it back up and it runs even more like crap, i let it idle for a few min and it gets no better. I drove it to the next parking lot to get out of the way and it was a total turd it wouldn't even go above 10mph.

I had the truck towed to a local diesel mechanics house, he is bringing home a scan tool to check any codes (no check engine light) and check all the fuel pressure. I am just wondering what i should be expecting....fuel injectors? hpop? valve cover harness? any ideas?

I don't know if it matters but i have an afe intake, straight pipe exhaust, and DP Tuner.
kjmracer14 is offline  
post #2 of 4 Old 11-18-2009, 02:34 PM
Powerstroke.org Fanatic
 
01flatbed's Avatar
 
Join Date: Sep 2009
Location: Amherst, NY and Alfred, NY
Posts: 111
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
by fuel light do you mean low fuel or water in fuel? maybe try draining the water out of the fuel bowl?
01flatbed is offline  
post #3 of 4 Old 11-18-2009, 06:59 PM Thread Starter
Member
 
Join Date: Jun 2009
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I meant low fuel, we found out today the reason it was ideling rough and not running right is because the hpop isn't holding pressure. Any ideas as to what could be causing that? Is there a valve or something that would release the pressure?
kjmracer14 is offline  
post #4 of 4 Old 11-18-2009, 07:24 PM
Compression Ignition Addict
 
dsljnky's Avatar
 
Join Date: Oct 2008
Location: Cincinnati
Posts: 631
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via AIM to dsljnky
mine was doing the same thing, i found that the ICP sensor was loose due to the late 5.6k mod, tightened up the spades in the connector, havent had a problem since

02 lb7
97 7.3
dsljnky is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome