No instruments, truck won't start - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-05-2009, 08:31 AM
Powerstroke.org Rookie
 

Join Date: Jun 2009
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No instruments, truck won't start

No instruments or gauges or tach when cranking, truck won't start. Worked fine yesterday, this AM, kaput. 2003 F350 7.3 6 Spd CC Long Bed. Checked fuses under dash, all OK. Noticed that after key is turned on, after a few seconds there is a brief sound coming from engine bay on drivers side and somewhere below battery box. Other devices like radio, blower, interior lites, day time running lites, signal lites work. All advice appreciated. Thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 10-05-2009, 10:32 AM
Powerstroke Junkie


 

Join Date: Aug 2006
Location: Mayberry, NC
Posts: 8,309
Thanks: 0
Thanked 34 Times in 9 Posts
Feedback Score: 0 reviews
No WTS light or other dash lights is a sure sign of PCM failure. I would make sure fuse #30 is not blown too. If it is check your fuel bowl heater.

NCH
Reply With Quote Quick reply to this message
  #3  
Old 10-05-2009, 03:38 PM
Compression Ignition Addict
 

Join Date: Dec 2007
Posts: 4,847
Thanks: 1
Thanked 80 Times in 75 Posts
Feedback Score: 3 reviews
Mine did something similar, turned out to be the connection "post" at the top of the drivers side inner fenderwell where the battery (+) wire went to two fuseable links.

Easy to check, just look down in back of the airbox at the top of the well for a big red wire that goes into a 1X1" box. Pull up the cover and look for "green"
Reply With Quote Quick reply to this message
  #4  
Old 10-05-2009, 04:45 PM
Powerstroke.org Rookie
 

Join Date: Jun 2009
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Problem solved. Fuse #301, 30 amp, labeled "Ignition Switch" was blown. This fuse supplies power to Fuel Bowl Heater; which have been known to short and/or cause problems. Disconnected heater and all is now good. I live in Saskatchewan where the temperature can drop to minus 40, so I'm wondering if not having the heater is going to be an issue when the cold sets in. Thanks for the replies. This one was a cheap fix.
Reply With Quote Quick reply to this message
  #5  
Old 10-06-2009, 05:59 AM
Compression Ignition Addict
 

Join Date: Nov 2007
Posts: 2,355
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
You should be fine without the fuel bowl heater, glad you found the problem.
Reply With Quote Quick reply to this message
  #6  
Old 10-06-2009, 06:10 AM
Powerstroke Junkie


 

Join Date: Aug 2006
Location: Mayberry, NC
Posts: 8,309
Thanks: 0
Thanked 34 Times in 9 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by ag-lad View Post
Problem solved. Fuse #301, 30 amp, labeled "Ignition Switch" was blown. This fuse supplies power to Fuel Bowl Heater; which have been known to short and/or cause problems. Disconnected heater and all is now good. I live in Saskatchewan where the temperature can drop to minus 40, so I'm wondering if not having the heater is going to be an issue when the cold sets in. Thanks for the replies. This one was a cheap fix.
Sounds like something I wrote, lol!!! Glad you found the problem!!


NCH
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:23 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors