Check engine light came on and went out? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-04-2007, 04:47 PM
Compression Ignition Addict
 

Join Date: Dec 2006
Posts: 457
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Check engine light came on and went out?

I always thought that once the check engine light came on it would stay on until it was reset-is this not always the case? I drove about 70 miles to see some friends on Friday and about 3/4 of the way there the check engine light popped on. The truck "hiccuped" once or twice on the way there, but otherwise no driveability issues.

I think the source of the hiccup is the CPS but I just haven't had time to change it yet. Anyway, I pulled in and we went out for dinner in their car so I got back in the truck about an hour and a half later. When I started it the check engine light was gone and it hasn't come back since. I spent a good portion of the weekend driving and I got one or two "hiccups" but no other issues and no light.

One of my friends has a scanner, so if I hook it up will something be stored since the check engine light was tripped?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-04-2007, 04:50 PM
Compression Ignition Addict
 

Join Date: Feb 2007
Location: nor- east PA
Posts: 154
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i'd hook up the scanner and see if there is any date in freeze frame storeage there that can point you in the right direction . don't start thorwing parts at it
Reply With Quote Quick reply to this message
  #3  
Old 03-05-2007, 03:51 AM
ADMIN AND TECH


 

Join Date: Oct 2006
Location: winston salem north carolina
Posts: 9,234
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
does sound like possible cam sensor going out
Reply With Quote Quick reply to this message
  #4  
Old 03-05-2007, 06:37 PM
Powerstroke.org Fanatic
 

Join Date: Dec 2006
Posts: 117
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
did you built up your boost past 25 lbs.?
Reply With Quote Quick reply to this message
  #5  
Old 03-05-2007, 08:46 PM
Nuckin' Futz


 

Join Date: Jul 2006
Posts: 700
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
yeah i lean toward the overboost...can you tell us the codes cause we can tell you alot based off those
Reply With Quote Quick reply to this message
  #6  
Old 03-05-2007, 10:16 PM
Premium Member
 

Join Date: Nov 2006
Location: Surrey B.C. Canada
Posts: 4,507
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I'm thinking CPS as well, unless you were getting on it and pulled an overboost light.

Gord.
Reply With Quote Quick reply to this message
  #7  
Old 03-06-2007, 07:30 PM
Powerstroke.org Fanatic
 

Join Date: May 2006
Location: South Carolina Lowcountry
Posts: 96
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Mine did the same Sunday. I was rolling along well in excess of the speed limit up I75 going to TN to visit my parents. Came up on an accident and had to creep/idle along for about 30 mins, SES light came on, truck felt like it was skipping, as soon as traffic broke free, punched it, light went out and truck ran fine. Later Sunday drove it down the mountain to town, mostly idle while dropping 1800 feet in a six mile drive, got to the bottom, SES light on again and skipping. Drove it down to Chattanooga, light would come and go, run rough and smooth out. Started home this morning, all smooth, no light, and once again idling down the mountain, light back on and running rough. Hoping it is not another injector crapping out, any ideas here?

Chris
Reply With Quote Quick reply to this message
  #8  
Old 03-06-2007, 07:41 PM
Powerstroke.org Fanatic
 

Join Date: Dec 2006
Posts: 117
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
sounds like you better hope its an injectors crapping out.... ses light and motor acting sick is nothing to play with
Reply With Quote Quick reply to this message
  #9  
Old 03-06-2007, 10:15 PM
Premium Member
 

Join Date: Nov 2006
Location: Surrey B.C. Canada
Posts: 4,507
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Just a suggestion, but have you checked the oil level in the HPOP reservoir? I'm no tech, but that doesn't sound like an injector to me, If it's not the CPS, it sounds like something intermittent, like oil level or something along those lines. I'm sure one of the techs will be along to tell me to go away soon hahaha.

Gord.
Reply With Quote Quick reply to this message
  #10  
Old 03-07-2007, 03:10 AM
ADMIN AND TECH


 

Join Date: Oct 2006
Location: winston salem north carolina
Posts: 9,234
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
if the motor is running at all the hpop should be full, his problem to me sounds more like a short harness , like comes on runs rough , pull codes and go from there
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:15 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors