Installed My Parts - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-04-2007, 03:33 PM
Fishing Fanatic

 

Join Date: Nov 2006
Location: Where the Navy sends me!
Posts: 400
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Installed My Parts/Pics in My Garage

Well with alot of cursing, I finally got it all done with the help of my wonderfully understanding wife! First install was the new 4 inch exhaust from Farmboy's diesel, next I went ahead and bought a wicked wheel. Then came gauges and A-pod pillar. Last but not least was a MAP fooler, and TC lock-up module! Alot of parts and alot of beer, but it is done, and MAN does this thing RUN!!! Pushing about 28 PSI of boost at max, exhaust SOUNDS GREAT!! Wicked wheel is just singing, and tires are just smoking!!! Man I love new parts that make things even faster!! Took a couple of pics, but don't know how to down size to the required file size to upload!!! Thanks for all the help and advice from the members on this site. Truck is getting just plain mean now!!! Next up??? Who knows! Thanks again guys!!

P.S. Is it that normal from EGT's to shoot from about 500 cruising around, to 12-1300 when you get on it hard. Man they shoot up there fast!!

Last edited by kefier2001; 03-05-2007 at 04:50 AM. Reason: Photos
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-04-2007, 03:56 PM
I LIKE CHROME :)

 

Join Date: Dec 2005
Location: New Salem, ND
Posts: 612
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via MSN to power95
sounds awesome!!!!!!!!!!!!!!!!!!
Reply With Quote Quick reply to this message
  #3  
Old 03-04-2007, 07:13 PM
Compression Ignition Addict
 

Join Date: Nov 2005
Location: Big Cypress Indian Reservation
Posts: 2,756
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by kefier2001 View Post
P.S. Is it that normal from EGT's to shoot from about 500 cruising around, to 12-1300 when you get on it hard. Man they shoot up there fast!!
Yes this is normal. Were (are) you running a tuner or chip without gauges?? Glad you got it up and running.
Reply With Quote Quick reply to this message
  #4  
Old 03-04-2007, 07:24 PM
im fat and ugly


 
Join Date: Aug 2006
Location: Shreveport, LA
Posts: 15,687
Thanks: 0
Thanked 5 Times in 5 Posts
Feedback Score: 0 reviews
oh yeah my egts shoot through the roof when i get on it
Reply With Quote Quick reply to this message
  #5  
Old 03-05-2007, 02:59 AM
Fishing Fanatic

 

Join Date: Nov 2006
Location: Where the Navy sends me!
Posts: 400
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I was running for a little while without guages, but I would only get on it for about 5 sec every now and then. Very glad I got all my goodies installed now. I got to figure out what to do next!! Probably will have to be tires, since these will be gone soon!! :burnout

Last edited by kefier2001; 03-05-2007 at 04:38 AM.
Reply With Quote Quick reply to this message
  #6  
Old 03-05-2007, 04:50 AM
Fishing Fanatic

 

Join Date: Nov 2006
Location: Where the Navy sends me!
Posts: 400
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Added some pics in my garage!! Not the best photos, but hey I took some! LOL. Thanks again guys for all the advice and help!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:06 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors