10mpg wtf! - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 8 Old 09-29-2009, 03:18 PM Thread Starter
Compression Ignition Addict
 
Join Date: Sep 2009
Posts: 338
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
10mpg wtf!

OK like out of no where my milage dropped to like 10. This is with my Edge set to stock and I keep my foot out of it most of the time. Will a fuel filter cause this?
2000_f350 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 09-29-2009, 03:50 PM
JJR
Compression Ignition Addict
 
Join Date: Nov 2006
Location: Omaha
Posts: 304
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Yes it will but you would notice a lack of power. Don't know your mileage but worn and dirty injectors can cause this too. Check fuel filter and try adding some Seafoam to your fuel tank.
JJR is offline  
post #3 of 8 Old 09-29-2009, 03:52 PM
Super Moderator

 
Goose350's Avatar
 
Join Date: Nov 2008
Posts: 13,270
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 5 Times in 5 Posts
Feedback Score: 2 reviews
If you have 4x4 are your hubs locked? Do you feel the truck miss while cruising?

The Mullet Mod
Stock 2005 F-350 4x4
*Afe Intake
*4" TB Exhaust
*Scangauge
*SCT
*Bulletproof Diesel oil bypass
*Bulletproof Diesel water pump
*Tuned FICM
Goose350 is offline  
post #4 of 8 Old 09-29-2009, 06:11 PM Thread Starter
Compression Ignition Addict
 
Join Date: Sep 2009
Posts: 338
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Truck feels fine. Idle is a bit rough. But I think it's always been that way. Still has enough power to smoke the tires. Could a fuel filter cause this? I did add power service to this fillup. I don't know but something has changed. No service engine soon light or anything. I should get better than 10 with no tune and a lite foot rite?
2000_f350 is offline  
post #5 of 8 Old 09-29-2009, 07:38 PM
Compression Ignition Addict
 
carpman15's Avatar
 
Join Date: Aug 2009
Location: near madison wisconsin
Posts: 161
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
if your not towing i would think you should get atleast 15mpg i think i get about 16 to 18 with my late 99 f250

99 f250 std cab w/8 ft service box 4wd 7.3l 6spd manual black

-foil delete
-custom straight pipe (out the side)
-ais intake
-a small 75 to 100 hp chip
carpman15 is offline  
post #6 of 8 Old 09-29-2009, 07:43 PM
Compression Ignition Addict
 
jamstoyz's Avatar
 
Join Date: Jul 2007
Location: michigan
Posts: 4,241
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
does it idle rough on cold starts? if so, get a re flash. that will help your mpg's. also check your air filter. a dirty filter will drop mpgs.

05 Single Cab Short Bed
*03 Turbo*Stroked Injectors*AFE Stage 2*Small mouth Intake*SCT With Eric's Extreme Race*4.30 Gear*Best ET 13.5@99MPH*
jamstoyz is offline  
post #7 of 8 Old 09-29-2009, 07:46 PM
Premium Member
 
ryandamo's Avatar
 
Join Date: Jun 2009
Location: Connecticut
Posts: 1,205
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
can a faulty icp sensor cause this, ive heard this somehwere dont remember tho


2016 F450 6.7L XLT 4x4Dump, bone stock
1994 F250 7.3L XLT 4x4 ZF5 , Centurion, 4" Lift, 6637, Gulf Coast Bypass Filter, Big fuel tanks, dana 60 swap, No longer dually
1997 F350 7.3L XLT 4x4Dump, E4OD, 4 in exhaust, TS 6 position, 3/8 Trans line+external filter
2013 Scag Turf Tiger 61" 1.1L Caterpillar Diesel
1960 John Deere 440 Backhoe 2-53 detroit
ryandamo is offline  
post #8 of 8 Old 09-29-2009, 07:56 PM Thread Starter
Compression Ignition Addict
 
Join Date: Sep 2009
Posts: 338
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I put a diy intake on about 2 weeks ago. It's clean. It runs a bit smoother when it's cold. It also starts faster. Any of this info help any?
2000_f350 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome