I Know I know another glow plug issue... - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-23-2009, 02:20 PM
Member
 

Join Date: Jun 2007
Posts: 50
Thanks: 3
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I Know I know another glow plug issue...

So i have seen all posts about cold starts and gp's and gpr's, but check my issue out. K... 99, f250, will not start at temps around or below 60 degrees. If attempted, it just turns and chokes and blows out white stinky smoke. I will easily start right up if plugged in over night, or if the no no bad bad juice is sparyed in the filter. So turn key on, hear the relay click on, lighgoes on then off as normal. I just upgraded to the stancore gpr, and still have the issue at hand. Was about 55 degrees other night and no luck. So, glow plug replacement in order, or could this be more of a injecter problem perhaps? Now remember were only talking 60 degrees or below here. O and By the way new batteries and altenator. Truck runs great no lag or anything of anykind when running. Mods are as follows..

evolution tuner
FBD 4" turbo back exhaust
NAPA Tymar DIY intake
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 09-26-2009, 07:18 PM
Member
 

Join Date: Jun 2007
Posts: 50
Thanks: 3
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
one more time.. Anyone???
Reply With Quote Quick reply to this message
  #3  
Old 09-26-2009, 11:17 PM
Compression Ignition Addict
 

Join Date: Mar 2008
Posts: 641
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
had same problem with mine, check the glowplugs themselves, just cause the relay is good doesnt mean the glowplugs are good. my gpr is bad, but for me to start it at the beginning of the day, i just short the 2 big terminals across for about 10-15 seconds and she fires right up, ive put 4 glow plug relays on my truck in a year and a half, i wont get one til winter gets here. It sucks dishin out 50 bucks each time to replace it. but check into that. pull the valve covers and test the plugs.
Reply With Quote Quick reply to this message
  #4  
Old 09-28-2009, 06:01 PM
Member
 

Join Date: Jun 2007
Posts: 50
Thanks: 3
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Well Im getting all new glow plugs tomorrow and Ill jut replace them all instead of guessing. I should also probably replace valve cover harness while im at it. Cross ur fingers, other wise injectors are probably shot.
Reply With Quote Quick reply to this message
  #5  
Old 09-28-2009, 07:29 PM
Compression Ignition Addict

 

Join Date: Jul 2009
Location: Lochbuie, Co
Posts: 1,176
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Mine is doing the same thing and all I got when I was looking for answers was to try the stancor mod, let me know if changing the glow plugs works. That's what I'm thinking of tryin next
Reply With Quote Quick reply to this message
  #6  
Old 09-29-2009, 05:51 AM
Powerstroke Junkie


 

Join Date: Aug 2006
Location: Mayberry, NC
Posts: 8,309
Thanks: 0
Thanked 32 Times in 9 Posts
Feedback Score: 0 reviews
No need for guessing, and NO you don't need to replace the UVC harness unless yours are in poor shape.

Troubleshooting GPR & GP's

NCH
Reply With Quote Quick reply to this message
  #7  
Old 09-30-2009, 08:41 PM
Compression Ignition Addict
 

Join Date: Mar 2008
Posts: 641
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
How many miles are on the truck? cause I have had a problem with injector 0-rings drying out and cracking from cheap oil. after replacing 2 o-ring sets, i just decided to replace all of them and be done with it. I noticed a big performance difference just in doing that. mine would spit, sputter and hesitate upon acceleration over 2,500. It would always fall on its face, even with my edge evo on stage 3, now it will run straight to red. mine also white smoked cause of the bad o rings. i would pull an injector and check the big o-rings at the top of it, if they are cracked or shrivelled, i would start replacing them. might try that. its like $12-15 per injector kit. comes with everything for the injector, but be careful when you pull the injector out that the brass ring around the injector nozzle comes out with it, it gets replaced too. had one of those come off inside the head. Good luck.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:23 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors