4 wheel drive light? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-17-2009, 07:07 AM
Powerstroke.org Rookie
 

Join Date: Aug 2009
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
4 wheel drive light?

As I said I'm new here. My truck is going into 4 wheel drive but there is no indicator light on the dash or even the switch is not illuminated, is this normal? does anyone have any ideas on the problem?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-17-2009, 07:28 AM
Almostdunfukinwidit


 

Join Date: Nov 2006
Location: Trempealeau, WI
Posts: 30,944
Thanks: 105
Thanked 88 Times in 82 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to Dave
Check the fuse for the indicator light. Or the bulb might be out
Reply With Quote Quick reply to this message
  #3  
Old 08-17-2009, 07:30 AM
Powerstroke.org Rookie
 

Join Date: Aug 2009
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I thought about the fuses but i don't have an owners manual on it?
Reply With Quote Quick reply to this message
  #4  
Old 08-17-2009, 07:34 AM
Almostdunfukinwidit


 

Join Date: Nov 2006
Location: Trempealeau, WI
Posts: 30,944
Thanks: 105
Thanked 88 Times in 82 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to Dave
Google search an online PDF manual. I know they are out there
Reply With Quote Quick reply to this message
  #5  
Old 08-17-2009, 08:01 AM
Powerstroke.org Rookie
 

Join Date: Aug 2009
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ok now that that question is answered i have another, my rear brakes don't seem to be working very much (rotor's are a bit rusty) are there any kind of fixes or is this normal on these trucks?
Reply With Quote Quick reply to this message
  #6  
Old 08-24-2009, 09:14 AM
Powerstroke.org Rookie
 

Join Date: Aug 2009
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
ok back to the 4 wheel drive now.(brakes are good now) the light is not working but it is engaging. front passenger hub is stuck in auto. fuses all seem ok. i dont know where to go to next.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:36 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors