cruise control problem - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 08-13-2009, 03:21 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Aug 2009
Posts: 20
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
cruise control problem

i have 2003 7.3L superduty when i set the cruise on it quit and come back on and keep doing that and then sometimes it will work fine is the cruise control getting bad or there something else i should look for thanks tom
tomf350 is offline  
post #2 of 5 Old 08-13-2009, 04:26 PM
Compression Ignition Addict
 
jbawilliams's Avatar
 
Join Date: Aug 2006
Location: Iowa
Posts: 206
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
on my 96, i had a similar problem - sometimes it would work great and sometimes not for one minute in a row. Believe it or not, after i had to repair my UVC harnesses and gasket, the problem totally went away. I suspect that the short in the UVC harness was tripping the check engine light (cruise didnt work with CEL on), but only so briefly that I never saw the light. It was not until short got so bad that it was always on that I found the problem. It may seem like a stretch, but it may be worth checking out.

No trees were harmed in the sending of this message, however, a large number of electrons were terribly inconvenienced.
jbawilliams is offline  
post #3 of 5 Old 08-14-2009, 01:59 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Aug 2009
Posts: 20
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i have no check light that goes on i was watching it going down the road but what is the uvc harnesses
tomf350 is offline  
post #4 of 5 Old 08-14-2009, 10:27 AM
Thats Mr. Oil Leak.....

 
MrJohnWayne's Avatar
 
Join Date: Oct 2006
Location: Waller/Magnolia
Posts: 9,604
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Thanks: 9
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
could be a bad brake pedal switch or a bad clutch pedal switch if you have a manual.

John Wayne
Owner and Operator of the
REDNECK VALDEZ
You can find me on FaceBook
MrJohnWayne is offline  
post #5 of 5 Old 08-16-2009, 05:53 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Aug 2009
Posts: 20
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
where do i find the brake pedal switch at
tomf350 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome