Battery light on - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 07-22-2009, 02:05 PM Thread Starter
Member
 
dragracing_123's Avatar
 
Join Date: Jun 2008
Location: Cullman,Alabama
Posts: 62
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Battery light on

I got some problems my battery light comes on and stays on. But the battery voltage shows it to be way high in volts. I just bought new batteries and top alternator what else is there i can do or need to do to fix this ****???? Thanks if you know any information please post it

2000 F-250 PSD 7.3 L
Rough country nitro shocks
20 inch moto x wheels
35 inch toyo open county mt
5'' turbo back exhaust
Sinister SS Up pipes
Sinister 160cc/80% injectors
RR Billet Wheel
1.0 ar housing
RR CCV delete
RR AIH delete
Non EBPV pedestal
Machined high flow outlet
Bully dog shift kit
RR HPX crossover
Zoo dad mod
Foil delete
PHP Hydra(Chatham Tunes)
Autometer Gauges
AFE stage ll intake
Cool Twist Intercooler
08-14 tailights
05 Harley headlights
dragracing_123 is offline  
post #2 of 4 Old 08-06-2009, 06:09 PM
Powerstroke.org Rookie
 
Join Date: Jul 2009
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Keep me in the loop on what you find. I have the same problem.
briterone is offline  
post #3 of 4 Old 08-06-2009, 06:50 PM
Powerstroke Techie

 
forddieseldoctor's Avatar
 
Join Date: Oct 2007
Location: Saint Cloud, WI
Posts: 4,464
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Quote:
Originally Posted by dragracing_123 View Post
I got some problems my battery light comes on and stays on. But the battery voltage shows it to be way high in volts. I just bought new batteries and top alternator what else is there i can do or need to do to fix this ****???? Thanks if you know any information please post it
Do you have dual alternators? You either have a ground issue to one of your alternators or the voltage sensing wire is open(orange/light blue) if both of those are ok then your voltage regulator is bad which is in the alternator.

Ford Senior Master Diesel Tech
forddieseldoctor@att.net


IF YOU DON'T WANNA STAND BEHIND OUR TROOPS
THEN FEEL FREE TO STAND IN FRONT OF THEM


Meet Double Aught
2000 F250

forddieseldoctor is offline  
post #4 of 4 Old 08-07-2009, 03:17 AM
Powerstroke Junkie


 
NCHornet's Avatar
 
Join Date: Aug 2006
Location: Mayberry, NC
Posts: 8,308
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 51 Times in 11 Posts
Feedback Score: 0 reviews
I would replace your grounds, the PSD's didn't have the best grounds.

NCH

NCH
Proud Father of USAF Airman


2000 F350 DRW,CC,LB, 4X4, Western Hauler Pkg.
Ford AIS/ BTM, FTVB
My CCV MOD, Coolant filter
06 Grill, 05 lights,6.0 trans cooler
Cyro/Hawks, JVC Touchscreen HU, JL C5's, Infinity 800watt amp,
DP tunes, 60 tow/80 e/120 race, on a SCT2 tuner
P3 controller, Brite Box Turbo Lifesaver
KMC Wheels x 4

http://s132.photobucket.com/user/NCH...=recent&page=1

Friends Don't Let Friends Drive Trucks With Generic Tunes
NCHornet is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome