New to forum/ lift kit installation advice? - Ford Powerstroke Diesel Forum
99-03 7.3L Exterior Discussion Body and Accessories Talk

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 09-23-2013, 11:39 AM Thread Starter Rookie
Join Date: Sep 2013
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
New to forum/ lift kit installation advice?

Hello everyone, I know this isn't the place for intros but I am brand new to the forum and already looking for advice!!
I have gone back a ways and still looking around but hoping to get some good advice on a lift kit installation.
I have a 2001 F-250, 7.3L dsl, 4WD Crew Cab. I have already purchased my 4" Skyjacker brand lift with new springs for the front.
Basically what I need is any do's/ dont's, "instructions will say this but do that" type advice. I do have a friend to help but neither of us have done a lift kit before.
Thanks in advance.
cdunc24 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome