Possible bad torque converter? - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 05-11-2014, 12:30 PM Thread Starter
Compression Ignition Addict
 
RAMKILLER97's Avatar
 
Join Date: Sep 2011
Location: Hull, MA
Posts: 298
Thanks: 3
Thanked 4 Times in 4 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Possible bad torque converter?

Was driving back from Wally World today and after I began to accelerate from a light the truck shifted one-two fine then was having trouble finding third. I figured it was the shift valve that stuck on me a few months back, but then I let off the throttle and it shifted into third. If I give it gas the rpms would jump and I would hardly accelerate. I can baby it into OD and it does the same thing. Also this is the first warm day of the year around here and it got to 80 while I was driving. Trans read 175 until it began having this problem then it rose to 200 until I was able to get to a slower road and it cooled back off to 180ish. Also my chip is not currently in the truck so it's not a tuning issue either. Also the trans fluid is full and red.

2003 Excursion Eddie Bauer 7.3
6 Inch ProComp Lift, 315/75/16 BFGoodrich All Terrain Tires, BTS Transmission, 175/100 P.I.S. Injectors, PMF Traction Bars, Garrett 38r, International Up Pipes, Dyno Proven Tunes, 6.0 Transmission Cooler, CCV mod, MBRP 4" Turbo-Back Exhaust, RiffRaff Over Boost Code Regulator, Moto Metal MO951 Black Rims, Dual Sky Jacker Steering Stabilizers, GlowShift Gauges, Mile Marker 449SS Lockout Hubs, 6637 Intake.

Putting this old PMR truck to the test....
RAMKILLER97 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 05-11-2014, 02:04 PM Thread Starter
Compression Ignition Addict
 
RAMKILLER97's Avatar
 
Join Date: Sep 2011
Location: Hull, MA
Posts: 298
Thanks: 3
Thanked 4 Times in 4 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Let it sit for a while and drove it with the trans temp at 120 and it shifted and drove fine. Guess it's a temp related issue. 6.0 cooler here I come....

2003 Excursion Eddie Bauer 7.3
6 Inch ProComp Lift, 315/75/16 BFGoodrich All Terrain Tires, BTS Transmission, 175/100 P.I.S. Injectors, PMF Traction Bars, Garrett 38r, International Up Pipes, Dyno Proven Tunes, 6.0 Transmission Cooler, CCV mod, MBRP 4" Turbo-Back Exhaust, RiffRaff Over Boost Code Regulator, Moto Metal MO951 Black Rims, Dual Sky Jacker Steering Stabilizers, GlowShift Gauges, Mile Marker 449SS Lockout Hubs, 6637 Intake.

Putting this old PMR truck to the test....
RAMKILLER97 is offline  
post #3 of 3 Old 05-12-2014, 09:04 AM
Member
 
Join Date: Dec 2011
Location: Winston Salem
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
Feedback Score: 0 reviews
200 is hot but mine has been that hot before and suffered no problems. If the temps are related to your shift problems it sounds like it may be signaling deeper pending problems. I am no expert by any stretch
tvengineer is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome