Torque converter help - Ford Powerstroke Diesel Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 02-16-2014, 08:41 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Feb 2014
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Torque converter help

Hello all, I believe my truck just lost a torque converter but I'm not positive. So from the beginning, I started to notice my truck seemed like it was missing while accelerating. The rpms would vary up and down about 200 rpm. Then a couple days ago I pulled in a parking lot and couldn't come to a stop without it lurching and almost dieing. So I kept driving back to my work then right before I pulled in our driveway I lost power completely in all gears, it was free revving. Also my battery light has been on ever since I bought the truck. The reason I say this is because I've done some reading about why a torque converter would lock and unlock and came up with electric noise possibly from a alternator and my truck killed 2 battery's that the previous owner put in in 2012. So now I'm guessing to replace the alternator? And a torque converter. My main question is do you guys think it got my transmission to? The transmission only has 50k according to a receipt from the PO and he said it had upgraded clutches and stuff. Thanks and sorry for the long story.
Red9999 is offline  
post #2 of 4 Old 02-17-2014, 10:17 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Feb 2014
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Also the od light has been flashing. So obviously something was making the torque converter lock and unlock, I still have to figure out what, but at this point nothing could be making the converter not grab at all right? So now matter what I'm in it for a torque converter?
Red9999 is offline  
post #3 of 4 Old 03-27-2014, 10:04 PM
Compression Ignition Addict
 
heykw's Avatar
 
Join Date: Feb 2008
Location: Orlando FL
Posts: 571
Thanks: 8
Thanked 6 Times in 6 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
What did you do?

Excursion 02 4x4 Silverline exaust superchip tuner

Excursion 2000 4x4 300K miles 238/100 P.I.S. Injectors 38RW/ billet wheel dyno proven tunes

99 F350 7.3 4x4 body build date 02/98 motor build date 12/97 19.5 ricksons (Sold)
heykw is offline  
post #4 of 4 Old 03-28-2014, 10:25 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Feb 2014
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
The fluid was pretty sparkly so I pretty much made peace with the idea I would have to pull it and rebuild it. I was told, by Jon woods to pull the transmission pump and see if there is chips inside to really tell if I need a rebuild. But I think I'm going to do it myself anyways because I already have it pulled out. I haven't pulled the pump yet so I don't know for sure but I bought a diamond t torque converter and I'm going to put a suncoast rebuild kit in it. Ill let everyone know on the diamond t after I drive it. A bts would be nice but for a stock truck with tunes and I can't justify spending half what the trucks worth on a transmission.
Red9999 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome