trans wont shift unless I let off throttle - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-02-2014, 09:10 AM
Powerstroke.org Rookie
 

Join Date: Jun 2013
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
trans wont shift unless I let off throttle

hello last night drifting my 2000 f250 7,3 truck shifted fine then heading home from a dead stop accelerating it wont up shift no matter how high off rpm i hit unless you let off the throttle while moving then it will and it does this in every shift.

also noticed the overdrive light on my shifter blinking

any ideas?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-02-2014, 09:15 AM
Powerstroke.org Rookie
 

Join Date: Jun 2013
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
BTW fluid level is fine, color was dark,
truck has 180,000 ts programmer that dosnt like staying plugged in and van turbo with ww2

is it a electric harness or old school vacuum line or what
Reply With Quote Quick reply to this message
  #3  
Old 01-02-2014, 09:21 AM
Powerstroke.org Rookie
 

Join Date: Jun 2013
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
also i have a torque convertor lock switch, i was wide open for a while not sure if tc is bad or if snow and cold temps screwed with wiring or what??
Reply With Quote Quick reply to this message
  #4  
Old 01-04-2014, 06:58 AM
Compression Ignition Addict
 

Join Date: Oct 2011
Location: Chico, California
Posts: 3,498
Thanks: 17
Thanked 100 Times in 95 Posts
Feedback Score: 0 reviews
possibly issue due to your chip coming off/being loose.

use duck tape to hold the chip on lol
Reply With Quote Quick reply to this message
  #5  
Old 04-26-2014, 12:00 PM
Member
 

Join Date: Jul 2012
Posts: 68
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
I had a similar issue. trans getting hot. od light blinking. then I got home to back in the driveway and wouldn't shift into reverse. then after a bit I magically had reverse. I also have a ts chip. ill be sure to check and see if its loose. I drove three hours last night to Missouri with no issues. the next day is when it started acting up.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:05 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors