Burping Tranny - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 08-04-2008, 11:26 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Aug 2008
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Burping Tranny

I have a '99 F350 4x4 auto (first Ford, first diesel). We just picked it up before vacation. We drove 650 miles to Colorado without an issue. Went over Monarch pass (11,000 ft) without an issue. Got to the first campground and fluid was coming out of the overflow. It was bright red and no burnt smell. We let it cool off and had to add 0.75 qt to get it back to the full (checking at temp). I am being told that this isn't unusual for this truck. true or false? Do I have a problem? Should I go ahead and add a temp guage and extended pan? I only pull a 3000# trailer at legal speeds.
Randy820 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome