6 speed slave cylinder problems. - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-04-2008, 08:32 PM
Powerstroke.org Rookie
 

Join Date: May 2007
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
6 speed slave cylinder problems.

Truck is a 99 F350 with 6 speed. About 30k on a new clutch. A week ago I put in a new slave and master for the clutch. Worked great for about a week, maybe 100 miles. Today pedal got real hard and there is a noise when the clutch is pressed in when running. I pulled the slave and the two plastic retainers are broke, and I think they are supposed to stay in one piece. Truck also does not want to hardly turn over now and I have never had trouble like that before. Anyone hve any ideas? TIA
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-05-2008, 04:23 AM
Compression Ignition Addict
 

Join Date: Jan 2008
Location: Wind Gap, Pa.
Posts: 212
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Never had one apart, but sort of sounds like the throw out bearing is jammed. Can you get the truck in gear?
Reply With Quote Quick reply to this message
  #3  
Old 07-05-2008, 04:29 AM
Compression Ignition Addict
 

Join Date: Jul 2006
Location: Covington Tennessee
Posts: 450
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
The 2 straps are not supposed to be connected. "what my instructions say " There to hold the piston back while installing.
Reply With Quote Quick reply to this message
  #4  
Old 07-05-2008, 06:56 AM
Powerstroke.org Rookie
 

Join Date: May 2007
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Looks like it may need to go to the tranny shop again.
Reply With Quote Quick reply to this message
  #5  
Old 07-07-2008, 10:21 AM
Compression Ignition Addict
 

Join Date: Jul 2006
Location: Covington Tennessee
Posts: 450
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
There is supposed to be a plastic cap on the end of the rob or it will be hard to shift.
Reply With Quote Quick reply to this message
  #6  
Old 07-16-2008, 01:37 PM
Powerstroke.org Rookie
 

Join Date: May 2007
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Got the truck back from the tranny shop yesterday and the fork that moves the thoughout bearing was broke. Also the clutch was almost shot. Only 30k on a clutch doesn't seem very good.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 07:44 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors