Broken something? - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 07-26-2013, 09:32 PM Thread Starter
Compression Ignition Addict
Wyofordpower's Avatar
Join Date: Jun 2012
Posts: 155
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Broken something?

The other day I was justly driving around town, shifted to 3rd and there was a small thunk noise, barely audible over the motor, and all forward motion ceased. 99 f250 zf6 by the way, stock with just 4" straight pipe exhaust.

Dad gave me a tow home and just got it up on jackstands to try and diagnose.

With the hubs locked in, all four tires spin if one tire is turned by hand, so probably not transfer case. That is with the tranny in neutral.

With the tranny in gear and hubs locked and 4x4 on, the front tires spin, but back do not.

Anybody think that it could be anything else but the clutch? I'm gonna pull the trans tomorrow to look at the clutch, but if it could be something else I would love to know what it could be.

Also is there a clutch inspection place on the tranny. I couldn't see one today and all I see through the front plastic piece is flywheel.

Sent from Free App
Wyofordpower is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome