I need advice ASAP! - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 01-30-2013, 04:50 PM Thread Starter
Powerstroke.org Rookie
NorthwoodsF350's Avatar
Join Date: Jan 2013
Location: Central Minnesota
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Exclamation I need advice ASAP!

Guys, I'm new here and just bought my first 7.3 after having the typical 6.0 nightmare that lasted a year and a half. I am happy with the truck so far, but today after warming up for 15 minutes (it was 16 degrees out) I took it 2 miles into town and my trans wouldn't get me past 15mph on the way home. Engine runs fine, I bought the truck from the state with 244k on it. It blows a little white smoke the first 10 minutes when it's cold out, but fine after that. Any ideas on the tranny issue?
NorthwoodsF350 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome