Transmission Not Grabbing - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-27-2013, 11:19 AM
Powerstroke.org Rookie
 

Join Date: Jan 2013
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Transmission Not Grabbing

99 psd

Just put another engine in the truck and was driving it for the first time today. When Im driving at about 1800-2000 rpm it will stop pulling the truck and it will not start again till it reaces about 2500rpm. Any ideas? Thanks.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-28-2013, 11:39 AM
The Screwy HEUI
 

Join Date: Jan 2008
Location: Smithfield, RI
Posts: 4,585
Thanks: 5
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by stroking for life View Post
99 psd

Just put another engine in the truck and was driving it for the first time today. When Im driving at about 1800-2000 rpm it will stop pulling the truck and it will not start again till it reaces about 2500rpm. Any ideas? Thanks.
I'm not sure I understand your question. You mean it'll stop accelerating at about 1800-2000?
Reply With Quote Quick reply to this message
  #3  
Old 01-28-2013, 02:34 PM
Powerstroke.org Rookie
 

Join Date: Jan 2013
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Yes it'll stop excleratinge at 1800-2000 and the start excelerating at 2500. Iv only gotten to secon gear but it's doing it in both.
Reply With Quote Quick reply to this message
  #4  
Old 01-28-2013, 03:21 PM
Premium Member
 

Join Date: Jan 2013
Location: southern indiana
Posts: 147
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
im guessing you have an automatic? i have a 99 to and when my tranny went i lost 3rd gear/reverse first, it wouldnt shift into 3rd and eventually shifted from 2nd to 4th, luckly i was on the way to the guys house that ended up doing my rebuild, he drove it and when at a stop and put in reverse it wouldnt go until it hit a certain rpm and then grabbed real hard and shot backwards, he thought it was building enough pressure to grab which means nothing to me but thats what mine did so if this sounds like what you have then it could be the same prob.
Reply With Quote Quick reply to this message
  #5  
Old 01-29-2013, 05:43 AM
The Screwy HEUI
 

Join Date: Jan 2008
Location: Smithfield, RI
Posts: 4,585
Thanks: 5
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Do you know what your ring & pinion gears are?
Reply With Quote Quick reply to this message
  #6  
Old 01-30-2013, 12:00 PM
Powerstroke.org Rookie
 

Join Date: Jan 2013
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have no idea
Reply With Quote Quick reply to this message
  #7  
Old 01-30-2013, 12:02 PM
7.3 4 Ever! Nothing else!
 

Join Date: Aug 2012
Posts: 4,169
Thanks: 1
Thanked 16 Times in 16 Posts
Feedback Score: 10 reviews
Quote:
Originally Posted by stroking for life View Post
I have no idea
pull the rear cover and check
Reply With Quote Quick reply to this message
  #8  
Old 02-05-2013, 11:44 AM
Powerstroke.org Rookie
 

Join Date: Jan 2013
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I figured it out. When I lifted my transmission to pull the engine I placed the jack on the transmission pan and smashed it a little In turn breaking open the oil filter. Replaced them both and now she's as good as new. Thanks for all the help guys.
Reply With Quote Quick reply to this message
  #9  
Old 02-07-2013, 08:47 AM
The Screwy HEUI
 

Join Date: Jan 2008
Location: Smithfield, RI
Posts: 4,585
Thanks: 5
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by stroking for life View Post
I figured it out. When I lifted my transmission to pull the engine I placed the jack on the transmission pan and smashed it a little In turn breaking open the oil filter. Replaced them both and now she's as good as new. Thanks for all the help guys.
Glad you figured it out, bro!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:18 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors