reverse bog down shut off/ delayed gear engagement - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 3 Old 06-23-2012, 06:39 PM Thread Starter
wps Rookie
Join Date: Jun 2012
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Exclamation reverse bog down shut off/ delayed gear engagement

225k miles
hypertech programmer
synthetic oil (recently changed)
hydraulic fluid levels fine no burning

When shifting into reverse engine bogs down and frequently shuts off. This also happens when coming to a stop/slowing down and when put in Drive. Tach needle drops but no check engine light or codes thrown. The camshaft position censor was replaced last year around this time. Not sure if its has gone out but when it failed it would cut off, throw code and check engine light would come on and would surge all of this while driving not engaging into reverse or drive. I've heard 7.3L's are notorious for cam pos sen but this seems beyond that. The other problem is the delayed engagement into reverse and drive. The engine revs then 2 seconds or so later it will slam into gear. When going through the gears it seems an electrical problem causing the truck to down shift or upshift at the wrong time. Like its confused and doesn't know what gear its in. The truck has been programmed for at least 6 years and nothing like this has happened. Was considering too much pressure on the tranny while programmed stage 3 has caused all this but after 6 years and no problems i kind of threw that hypothesis out. we pull a heavy center console fishing boat but not more than 5 miles to the lake and back. If anyone has any advise its greatly appreciated. Yes i could take it to a knowledgeable diesel mechanic but wanted to hunt down the problem before.
wps is offline  
Sponsored Links
post #2 of 3 Old 06-25-2012, 05:43 PM
Compression Ignition Addict
Join Date: Dec 2006
Posts: 1,248
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 7 Times in 7 Posts
Feedback Score: 0 reviews
cross leak in the trans pump, very common problem. Pressure leaks over in to the tc apply side and loads the engine down, sometimes killing it.
ipz2222 is offline  
post #3 of 3 Old 07-13-2012, 04:02 PM Rookie
Join Date: Jul 2012
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I'm having this same issue. How do you fix it?
Pinkdog is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome